Questions, discussions, news and updates regarding the Thinkwise Platform.
Recently active
Hello, I am trying to configure the Offfice365 Exchange connector. When I've gone though the steps of the manual (https://docs.thinkwisesoftware.com/docs/kb/exchange.html), and I run the SP: exh_sync_users, error 522 shows up. The error message is: “Er kon geen verbinding worden opgezet met de Exchange koppeling: System.Net.Sockets.SocketException (0x80004005): A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 10.0.0.30:9988 at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress) at System.Net.Sockets.Socket.Connect(EndPoint remoteEP) at System.Net.Sockets.TcpClient.Connect(IPEndPoint remoteEP) at UserDefinedProcedures.SendEvent[T](String exchangeServerIP, Int32 exchangeServerPort, DbToExhEventMessageBuilder message, T& result, String& errorMessage)” When I try to ping the given ip (10.0.
Does anybody know a good way to catch and prevent the error, when a file for some reason is locked for reading and processing? Executing API 'CreateFile' failed with error number 32. Error code 32 is ERROR_SHARING_VIOLATION . So the mailer cannot read the attachment file because something else is reading it. Besides the fact that you cannot really reproduce it until it happens, I cannot really find a way to catch this error upfront. I am using the file_exists function to check upfront if all documents exists, and even though all attachments can be found, at the time of sending the mail at occasions you get this error. The only solution I can think of now is to set the AccountRetryAttempts to 2 times to tackle this problem. But it's not the fanciest solution, anyone has experiences with this?
Until 2018.3 there was the post_sync procedure, which could be used to execute some statements after the synchronization process. The main reason why I am asking, is because I like to execute this statement after every sync: EXEC [dbo].[task_switch_path] @project_id = @project_id, @project_vrs_id = @project_vrs_id, @old_path = 'S:\Thinkwise\Applications\', @new_path = 'Applications\', @use_iam_project = 0 Is there any alternative?
I'm trying to convert a XML document with binary data to a zip-file via a self developed .NET Core 2.1 Web API using a process flow with a http connector. It's a follow up on this topic: https://community.thinkwisesoftware.com/deployment-12/moving-to-azure-sql-database-azure-file-storage-713#post2018 When testing the POST call via Postman and a simple .NET console application I receive the result as expected. When using the process flow using a http connector, it returns an error in the SF-Debugger: The remote server returned an error: (411) Length Required. This could indicate the Content-Length header must be applied, so I did: (Please note this is a fixed length, because the Content is also fixed value for now.) Unfortunately this results in an error: code:The 'Content-Length' header must be modified using the appropriate property or method.Parameter name: name at System.Net.WebHeaderCollection.ThrowOnRestrictedHeader(String headerName) at System.Net.WebHeaderCollection.Ad
I am trying to connect with a 3rd party API (Visma API based on Swagger) and for some reason I can't seem to get an output from the HTTP connector. For testing purposes I insert the connector output into a text file but the file remains empty. This is the debug error message in the application after triggering the process flow: code:Unexpected character encountered while parsing value: A. Path '', line 0, position 0. This suggests the connector output is empty which would explain why the file remains empty. If my assumption is correct then I don't understand why this happens. I have created the correct API call in the Insomnia application first and I get the expected json result: (Don't worry about data sensitivity because the data comes from a test account.) All the API call needs is a URL and these 5 headers (including a token). In SF I've set the parameters as follows: With 5 headers as a single value containing 5 lines being: code:Accept: application/jsonAccept-
I have a http connector in a process flow which communicates with a .net core 3.0 web api. The API can both produce XML and JSON: [HttpPost][Produces("application/xml", new string[] { "application/json" })]public IActionResult Post() If I do a call with no accept headers specified, this API returns the content as application/json. According to the documentation you can add headers to the HTTP connector: [ { "Key": "Accept", "Value": "application/json" } ] or: [ { "Key": "Accept", "Value": "application/xml" } ] To specify the expected result content type, so if XML is required, the last header should be applied. When I add this and execute the http connector it shows me the following message: The 'Accept' header must be modified using the appropriate property or method. Parameter name: name With a stack trace: The 'Accept' header must be modified using the appropriate property or method. Parameter name: name at System.Net.WebHeaderCollection.ThrowOnRestrictedHeader(String headerNa
Does anyone know a good algorithm to search a string on whole words only. For example, look for order and not order_line in a query. This could be an useful addition to code search.
I have a mobile application in development and I want to connect the mobile gui to the SF so we can see what we are developing. I already have a working connection to our test-IAM, which is located on a different instance . I am using SF 2018.3, Indicium To connect to our test-IAM I am using these settings: Meta source = IAM URL = https://url/mprod/api/iam Where mprod is the application in the IIS and the corresponding IAM is located at SERVER/test_instance. I want to connect to our SF which is located at SERVER/dev_instance. This does not work. Now I have the following questions: Do I need to make a separate application in the IIS to connect tot he SF? I already did so, and I called the application sf, in the appsetting: server = SERVER\\dev_instance ;database = sf_database. Is this correct? What will my URL look like? I think it should be https://url/sf/api/sf. However, this leads to a 404 error. When I try to retrieve the metadata (https://url/sf/api/sf/$metadata) I receiv
Is there a way to return the position of the cursor in a grid to a procedure. Normally the DEFAULT procedure is used for this, but it is not executed when you move through a grid.
I noticed when exporting a cube to excel that the filters, column and data labels are printed to the first two rows of the file. This has the effect that the first 4 as well as the 6th column of the actual data (from row 4 onward) consist of so-called merged cells. Is it possible to export without those first 2 lines and end up with an export that consists of only regular single cells, similar to the output of a regular grid? Quite a few of our users struggle to integrate the current output in their analyses.
In the new 2020.1 version I've created a screentype with a detail tab. In the screentype I've set the Show tab header to 'False’. I've used this screentype on a subject, with multiple details. I also created prefilters and a CONTEXT procedure on the subject, to hide or show detail-tabs according to the result of the prefilters. When I select a different prefilter, the CONTEXT procedure nicely shows and hides the proper detail-tabs, but WITH the tab header. Is this a feature or a bug?
In a main subject there are amounts for sales total and a purchase total (“Kale kostprijs”). The purchase amount is a total of a detail subject. When he result (sales total -/- purchase total) is positive (or zero), the result amount is shown in green, otherwise in red. After adding rows in the detail subject, the total of the details (purchase) is updated to 21.00, the result to -1.24 but the conditional layout for result is still showing green. Because it is a negative result, this should have been red. How can I update the color of the column result (conditional layout) at the same time as the “Kale kostprijs” and “Resultaat”? The extended property "RefreshOnTabSwitch” is already set to “Yes”.
How do i make a filed mandatory in the layout for a specific variant
We have an strange probleem with the popup field on the web by an task; In IAM the same problem exists that the buttons will disappear, so please advise me what to do?
What is the trigger to update ‘modified on’ within templates ? I see in my merged version using Full model, item Templates that when I sort on ‘modified on’ some templates have the same date as in the previous version (Trunk or Branche) and some not. But when I check the needed changes in that templates the changes are there ! It would be much better (and more trustfull...) if every changed templates has the right (=last) ‘modified on’ from Trunk or Branche, depending the chosen merge-action. I read the topic 'How is code history in templates supposed to work?’ but I'm talking about the date modified in the template itself
In the eLearning environment of TW the last step is an exam to become a 'Certified Thinkwise Associate’. At the moment I'm not sure what the requirements are? Is the exam about ALL the courses available, so including SQL and reporting Is it required to have done all the exercises (also from SQL) Are there any other requirements other than the courses available? I'm also curious in what form the exam is held. Open questions, multiple choice, cases etc. Perhaps an example exam to prepare would be nice, maybe that is already available?
Currently we have the development environment on a local SQL Server Environment (On Premise). The product is targeting the Azure environment (Azure SQL database & App Service). For testing purposes I want to be able to attach a project (branch) to an Azure SQL Database. Problem here is that it's kinda mixed mode: The SF-databases uses the Windows Active Directory (AD), whereas the Azure environment uses ‘rdbms’ users. When I set up the ini file I sort of have the following: metasource = sfserver = dev-serverdatabase = software_factoryauthentication = mswindowsproject = branchlanguage = engrdbms = sqlserverexecutionmode = developer Problem here I use mswindows as authentication. But the Azure SQL Server uses ‘rdbms’. I have a kind of a hack for it; I’ve added the same user/login to the on premise environment with matching name and password. That works, but I would prefer to use different credentials for the Azure environment. Is there a way to do this? Or should I see if it's possib
I read the topic how to create a new printer. That post helped me a lot to print a shipment document to a dedicated printer. But guess what … We have another site where we need to print shipment documents on another dedicated printer on that site. What’s the best way do do that.. I could create another report pointing to the same report definition and the only thing that changes is the printer. Or is it possible to create a report parameter where you can let the user choose the printer and by calling the report this printer is send to the report. So can I overwrite a report property (the printer) with a report parameter value. In that case I should create a table or a domain with printers to let the user choose in a drop down. (And why is the field related topics filled with ‘Introduction to Machine Learning Services on SQL Server? Will the machine decide it self which printer to use, that would be awsome :-) I can’t change that)
We have the following requirement: We would be able to let the user set a use filter for f.e. an ordernumber. The user can open the orders tab/document and set the filter. The filter data is stored in an employee_filter record in the application The next step is to let the user open a new tab/document - also orders - and the user set the filter to another order_number so he’s able to work on 2 different orders in one moment. So the 2nd should not affect the first opened tab. The problem is when setting the filter for the 2nd opened tab, de data on the 1st opened tab is changed conform the new filter when pressing F5 (refresh) We store the filter data in the application database per user.. A pre filter on the orders subject takes care of selecting the data based on the user filter as set in the application. At this moment we have 1 employee_filter record with user filter data. We could create more but the problem is that we are not able to assign a specific filter record to a specif
The users in our EndProduct can create employees for their company within the application. We have a task that creates a relation + an employee record. In addition to creating an employee we would like to be able to create an IAM user with the information and credentials the user has supplied. So we made a subroutine called ‘create_iam_user’. This subroutine does inserts/updates on the IAM database. After creating an employee record the subroutine will be executed. But when it does, we get the following error in return. The users in our EndProduct have no rights on the IAM database and the ‘User Admin’ rights are not granted. I tried altering the procedure to execute it as OWNER or as a SQL login that does have ‘User Admin’ rights. After changing the procedure the execution (via SSMS) of the procedure succeeded with a SQL login that has no IAM rights. However when trying to execute the procedure via the EndProduct user we still receive an error. Why doesn’t the ‘EXECUTE AS’ method work
We use a VDI solution for remote workers and need to know if we can move to a solution using Microsoft RDS servers with remote desktops or remote apps. Does anyone have experience running the SoftwareFactory Windows client on such a system? According to the documentation this is supported and “Depending on the amount of data and the use of the application the Windows GUI requires between 30 and 100 megabytes (MB) RAM memory per user.”. If you have experience in running the Windows GUI on RDS how many concurrent users can you run on each server and do you have any issues with memory, USER object or GUI object usage?
Is it possible to enable a warning to tell the user if their Caps lock is turned on? I know that the Windows GUI does have it but I don't seem to be seeing it nor being able to enable it for the Web GUI, hence the question. Kind regards, Mark Jongeling
I performed a DBCC CHECKDB on our databases and it found an error in our SF database: Msg 8947, Level 16, State 1, Line 1 Table error: Multiple IAM pages for object ID 349973069, index ID 1, partition ID 72057598823759872, alloc unit ID 72057598842699776 (type In-row data) contain allocations for the same interval. IAM pages (1:396048) and (1:292862). CHECKDB found 1 allocation errors and 0 consistency errors in table 'linked_project' (object ID 349973069). CHECKDB found 1 allocation errors and 0 consistency errors in database 'DB_software_factory'. repair_allow_data_loss is the minimum repair level for the errors found by DBCC CHECKDB (DB_software_factory). I have no clean backup and the DBCC is not able to repair the error. I can do a clean install of the SF, but I will need to export/import the projects. Is this possible? Are there other solutions, like replacing the 'linked_project' table?
Dear Thinkwise, Soon we want to install and use SQL server 2019. (Available since 4 nov 2019) We work with SF 2019.1, IAM 2019.1 (and higher), Indicium 2019.1.7 (and higher), WebGUI 2019.1.11 (and higher). On your website you only show support for SQL Server 2019 RC. (https://docs.thinkwisesoftware.com/docs/2019.1/kb/lifecycle_policy.html#microsoft-sql-server) Can you confirm that SQL Server 2019 in combination with the above named products is also supported? Yours sincerely, Eric
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.