Questions, discussions, news and updates regarding the Thinkwise Platform.
Recently active
I wonder how you can navigate back from a detail screen to a form in Universal, in case the detail screen is opened via a detail button. Like the scenario below:
Hi,For the process flow to send out email from the application , earluier SMPT connector was used. However after the client updated to microsoft365, SMTP connector is not supported and the emails were no longer sent.To overcome this Email connector is used instead of SMTP connector. However, I am getting the error for the From address in the email provider: 2023-12-07T16:50:16.8980307+01:00 [ERR] Process action "email_connector" in process flow "send_email_from_queue" in application 147 threw an exception. (dedd009e)Status Code: ForbiddenMicrosoft.Graph.ServiceException: Code: ErrorAccessDeniedMessage: Access is denied. Check credentials and try again. process flow : Email providerPlease let me know if I am missing something?Using Email connector instead of SMTP connector and giving the known credentials in the email provider to set up should be sufficient, isnt?Also the emails needs to be sent out from address provided in the application (that may differ) How can this be encorporat
Is it possible to block the use of a specific username. We see some hacking attempts with a specific username. Is there an option that username cannot be created? Or can we create a blacklist?
Hi!I’ve checked the community regarding refreshing tables in process flows. But I could not find a solution which complies with the wishes of our users.Our users mostly work in the windows GUI. One of the processes includes a view with a task. A pop-up containing another view appears after the user clicks on the table task. When the user is done with the pop-up, it is closed automatically. The previously mentioned view is still present after the pop-up is automatically closed. But I want to refresh that view. I have tried the following:Open document (try to use an existing tab = yes). Change filter (to open the record) Activate detail Refresh tableThis does work. But is not practical because it clears the filters applied by the user. It also takes some time because it tries to re-open the view. Auto refresh is also not very practical in our case because the view can vary from a couple of records to thousands. Can you help me finding a solution which might be faster and does not clear t
Our users are logged in through various methods. Some have managed systems, others log in via RDP. Sometimes a user has their files synced with Onedrive, others have a profile folder on a shared drive via redirection. This leads to reports with export to pdf setting being saved in various locations.For a process flow we were able to program one of these file paths by putting a username variable as part of the path but this renders the flow unusable for quite a few of our users. The flow uses a move file action but it often can't find the exported pdf file. Therefor we need a more generic approach.What folder does the export to pdf option use internally to determine where to save a file? I've tried %USERPROFILE%\Documents but already in my own case this leads me to the wrong folder.
Hey All,i have a lookup that looks at a table, the table does have multiple identical values for a specific collom.Universal gives me the duplicates : on the other hand in Web GUI the same column in the same environment in this case lab does not:What could be the reason for this?
I have the same problem as in this post, but in another context.Some info about our application:Built for Windows GUI RDMBS: SQL Server Dozens of customers will use our application (installed at their SQL server) Users are logging in using ‘Windows authentication’ We're still on IAM/Indicium 2022.2 (planning to upgrade) Indicium is running as a service process, listening on port 5000 What I want to achieve: users log in with their own name, so IAM application roles and rights can be used users do not need to be known in SQL security; so the SQL connection from the IAM application should be handled by either: - a service account; - or a SQL account; - or an application role.Question 1:How can I achieve this for the Windows GUI?Related to this, I created a user with ‘Authentication’ set to ‘IAM', and changed the password.I started the application using an INI file containing "Authentication = iam”. When starting, the IAM login shows but after entering username and password, the error “L
Hi, Found a bit of a bug perhaps, but i'm not sure if it's me or Software Factory/ gui. I have 2 tables; Order and Order_unit. Order_unit is a detail of Order, hidden by default. When a 'order_type’ field in Order is set to ‘unit’- we show the detail tab through ctx. I have a process flow with these steps; Add row Order --> Decision (check if 'unit’ or not)If not - stop. If yes - Activate Detail Order_unit → add row Order_unit. (in grid) This works fine, the second time OR when you select an old Order row, and open the unit detail. It feels/seems that Universal does not completely load the page/adding or something. The second row Order, and it works fine, also when 'previewing’ Unit tab. We are up to date with our gui and all. Any thoughts? Blommetje
Hi,in Azure SQL Database in Query Performance Insight → Long Running Queries I have a query (see screenshot) and I can’t seem to find what is triggering this query. In the second screenshot you can see that every execution takes about 7 seconds.I have an item table with a system versioning table called item_history in Azure database but I already checked in Software Factory if there is anything that could trigger the query but can’t seem to find anything.Does someone have an explanation for this ? Or can give me some pointers to look elsewhere.Thank you. Query in text:SELECT [tsf_valid_from],[tsf_valid_to],[$S],[$tabType] FROM (SELECT [tsf_valid_from],[tsf_valid_to],LAG ([tsf_valid_to]) OVER (PARTITION BY [item_id] ORDER BY [tsf_valid_from],[tsf_valid_to]) AS [$S],[$tabType] FROM (SELECT [item_id],[tsf_valid_from],[tsf_valid_to], 0 AS [$tabType] FROM [dbo].[item_history] UNION ALL SELECT [item_id],[tsf_valid_from],[tsf_valid_to], 1 AS [$tabType] FROM [dbo].[item]) AS R) AS T query item
I've made a report in TSF DevExpress Report Designer with one sql server data source using two versions of the same view (table). In DevExpress the report works perfectly, however in Thinkwise universal GUI it does not... I'm getting the following error message: ``2023-11-10T15:30:00.3996411+01:00 80002581-0001-fb00-b63f-84710c7967bb [ERR] An unhandled exception occurred while processing the request. (ffba027a)Prockees.Bootstrapper.ExecutionException: DevExpress.XtraReports.DataRetrievalException: Error when trying to populate the datasource. The following exception was thrown:Failed to connect to the database. To learn more, see the exception details.Exception details: Connection name: localhost_TCNTW_CREDITEUR_Connection Error message:A connection was successfully established with the server, but then an error occurred during the login process. (provider: SSL Provider, error: 0 - The certificate chain was issued by an authority that is not trusted.) ---> DevExpress.DataAccess.Sql.
Hello, My question: Is there a setting or a easy way to make it so that it always starts on page 1 of your detailed overview incase you select a new article?Case setting information:We have created a overview of all our productes, with the current stock (Left side). On the right side you can see a detailed overview of the articles selected. In the image seen below, I've selected an article with 140 in stock. On the right side you can see a detailed overview of all the indiviual 140 products. which are devided over 3 pages. In this example I've now clicked on page 2. But when I click on anotherarticle on the left, with less products (this time 18 products).The detailed overview shows that there are no results.The overview is stuck on Page 2. For the newly selected article it wants to show a detailed overview of the products on page 2.But for the articles there are only 18 products, so they are all on page 1. If I want to see the detailed overview of page 1 for this product, I’ve must fi
Hi All, We want to create a new app for getting Applicants to submit their details for job postings we have within the Group.The process that will be followed is first the applicant is reviewed and secondly upon approval they can get further access to complete their profile putting more details. If an applicant is Approved to be a suitable candidate for a position then he will be transfered to our main system for hiring process and further checks.I know we can have OPENID providers configured in IAM and we can do auto-provisioning, basically they can authenticate with the external provider and we can add them to a default User group. We have currently this configured for our main system with Azure which auto provisions new users within our organization. How can I achieve auto-provisioning for creating IAM users to a default user group? the users will not be part of our organization thus we need them as IAM users instead of External connected to an OPENID provider. Would it be possible
Hi, We use often code with XML in our templates, like for processing the response of an SOAP API or using multirow parameter.Then we have the square brackets in the code, like what also is needed for parametrized template.When we make changes in the code and save it, then the error below is popping up in the Deploy tab.For now we copy the code and apply the changes in the related template and then we need to generate the control procedure again before deploying it, but that is lot of extra work.We are using the TW 2023.2.12 release. Is there a better solution for this or can the interpretation of the code being improved that it is coming from XML?
In SF 2023.1, after completing a merge session that had a conflict on a control procedure template, the control procedure of the template that had the conflict will not get the status ‘Ready for review’ from the merge session. This results in developers not knowing which control procedures should be reviewed after a merge.When a developer manually puts the control procedure on status ‘Ready for review’, the resolved conflict from the merge is marked as a change however.Expected result: Completing a merge session should put all control procedures of templates with resolved conflict automatically on status ‘Ready for review’. I remember this worked in prior SF versions.
The user had a login account. The user maybe used the button remeber me, but this is not sure. That in IAM the user is removed. It ends up in a situation that the user gets a login screen, but the username and password are grayed out.We tried clear cache and remove history. On this browser no access is longer possible to Thinkwise. Anyone a clue how to clear this one?
The past months I have worked on an old app (2021.3) which runs in the Microsoft cloud (Azure, SQL Server and Web App).Now I have upgraded the 2021.3 version to 2023.2 (IAM and SF/Application), but I receive the message above and its blocking me from getting it to work. My question is: how do I fix this problem and get my apps to work?
After upgrading he SF from 2022.1 tot 2023.1, an existing model (± 5 years of development), is giving the following error: The error, stating ‘Unique index is equal to the full primary key’The consequence, according to the SF is the following: The consequence of this error, stating ‘Foreign key constraints may introduce dependencies on this unique index, causing it to become difficult to delete or re-apply. This will also result in errors during full code execution’However, when going through all the steps of creation, no errors occur.The solution, according to the SF:The solution of this error, stating that ‘Changing the index columns to not be equal tot he full primary key or delete the index’Since this was fine in version 2022.1, it is unclear what to do here.This was developed in collaboration with the professional services of Thinkwise. The usage if mainly for primary keys that include a date. All these indexes have the extension _unieke_datum (_unique_date but in Dutch). The exac
Hi, I have to generate an xml for importing invoice into EXACT globe. The xml will be generated using a sql code within a task. Can you please guide in what should be the CDATA format for the code? I tried below code for processing it: '<![CDATA[ ' +cast(i.display_invoice_number as varchar) + ' ]]>' as Description Below is the error after its processed in excat : Image from EXACT Removed the CDATA and sent it as below : CONCAT('< ', cast(i.display_invoice_number as varchar), ' >') as Description Still it was not processed in EXACT, and no error message was provided In the exact knowledge base its mentioned that below characters can be used : string Strings in XML can contain all normal characters except &, <, >, " and '. These characters need to be replaced by &amp;, &lt;, &gt;, &quot; and &apos; respectively So updated the Descritption to below code : '&lt;![CDATA[ ' +cast(i.display_invoice_number as varchar) + ' ]]&
I am starting the Universal GUI (2023.2.11.0.0) on Android (android versie 13) with a firefox browser (version 119.0.1).Login as a user and do my thing. Continue with other work. Phone turns into lock. Want to continue on my phone. Unlock it and the universal gui pops up, but it shows a black screen (mostly, sometimes white).Only solution is killing the application and start this again.How to fix the black screen situation?Addition on the topic. Chrome doesn't give a black or white screen hang. In chrome we see a hang situation, visible by continous turning of the refresh button. Firefox a black or white screen (hang situation)Also happening in the latest GUI version 2023.3.11.0.0Does anyone recognize this behavior?
We were able to customize the (first) login screen of Universal using the custom.css as mentioned in replies within the community. This follow up question is about the second login page, when Thinkwise is being used as a passthrough to an external authentication provider. In our case these are AusweisApp (Germany specific) and eIDAS (European). The first page shows the company logo, company name and a continue button. After this a second page is shown where the OpenID Connect provider can be chosen (AusweisApp or eIDAS). Is it also possible to customize (use customer branding) on this second login page?
hi,When I select multiple rows in a grid and execute a templated task, this will be executed once for every selected row. But when I have a table task at the start of a processflow, and start this task with 3 selected rows, the task is only executed once.Is there something I’m missing? I don’t need a multiselectparameter solution, cause the tasks can be executed one by one. I am using the multiselectparameter for another task, can this be interrupting the default handling?
Hello! I am trying to edit an usr_id for an IAM user and the patch request from the http connector fails. I have also tried to call the “task_rename_usr_general” in a process or a task, but it returns an error: “"not_authorized_usr_admin"”. I have to mention that if I want to execute the exact same task manually from IAM, it works, it just fails if I try to call it externally (in a SF process/task or in the SSMS). Do you have any idea what could be the problem or if I should try another approach?
Hi, We recently conducted a production upgrade, and as a result, the end application has become significantly slower. We've observed that the following procedure is being invoked for each user. It appears that this procedure is called during startup, leading to a prolonged delay. How can we address and resolve this issue?/* Create or alter stored procedure get_gui_elemnt. */ session_id 151, cpu_time: 212742, total_elapsed_time: 750783 session_id 153, cpu_time: 251607, total_elapsed_time: 1344832 session_id 160, cpu_time: 240716, total_elapsed_time: 1293270 session_id 178, cpu_time: 250101, total_elapsed_time: 623093 session_id 231, cpu_time: 133600, total_elapsed_time: 436721GUI version: 2023.1.10.0.1 Windows GUI and Universal are slow. My second question is: Can someone explain to me the origin of this query and why it is consistently running or suspended?(@source nvarchar(256))SELECT type, data FROM sys.fn_MSxe_read_event_stream (@source, 0)session info: host_name: DB4C000001 program
Hi,I want to change the color for badge number on the tiles.requirementcurrently the tile is as below : current situationI updated below in theme for it: from the documentSynced IAM, however the changes are not reflected in the windows GUI. Am I missing anything? Please advice. Thanks,Rucha Naik
If the user doesn't login within 4 minutes on the login screen, the redirect is lost and the user gets the “Indicium is running”-page. We have received multiple emails from confused users because the 'Indicium is running' page does not provide any further instructions on how to proceed. Reproduction steps: From any app, go to the login-page (This is a request with a redirect URL) Stay on the page for longer than 4 minutes Fill in the correct credentialsExpected flow: User is redirected to the redirect url that is provided with the initial requestCurrent flow: User is redirected to the root URL of the indicium and sees a page with “Indicium is running” Additional technical information:The cookie: “CookieTempDataProvider” has an expiration date of 4 minutes in the future. After that the cookie is lost and this is needed for the redirect URL. Possible related issues:
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.