Ask a question or have a conversation about the Thinkwise Platform
Recently active
With the deprecation of basic auth for office 365 SMTP is it possible to authenticate through other means in order to send e-mails?I am currently trying to use the SMTP connector to send e-mails but keep getting -2 status codes for this action Error LOG:Process action "send_email" in processflow "flow_anne_mail_test" in application 83 threw an exception. (571360e4)System.Net.Mail.SmtpException: The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.57 Client not authenticated to send mail. Error: 535 5.7.139 Authentication unsuccessful, basic authentication is disabledShould i be using another connector? Or switch to another SMTP service like sendgrid?
hi,As an ISV we deploy our solution to different customers, and some customers need extra fields in a table to add information. The fields are not part of other processes, just as an extra bit a information on the form.We created these extra freefields as freefield_01 to 10 and thats working fine. But is it possible to change the translation for these fields, so the enduser can see where the field is for? The translations should be entered in the end solution, and be save during an update of the model.Sounds like dynamic model, but has anyone done this before?
Weird question…..We have a client that is using the Universal Interface for their application. Outside of the Universal interface we have a seperate page where clients can register themselves. This creates an IAM account that they can login with.The client would like to integrate this registration form with the login form. The would mean we create a single page outside of the thinkwise application. On this page we have a regular form and a login form. Filling in the login form should result in opening universal and automatically login using the provided username/password. Is there a route to make this possible?
Hi,we just successfully tested an upgrade of our SF from 2021.3 to 2022.2.Next we tried to create the main trunk and noticed that during the “Validate definition” step we had an error on “User interface” > “Translation is unverified in ENG” > "Error while executing. More info can be found in Maintenance > Jobs > Validate definition.”Proposed solution is:Check the translation and set the verified flag.When reviewing translations is not required, this setting can be altered in the screen 'Configuration' under 'Settings'. This applies to all projects.Checking the related object the job "Validate definition” is displayed… 🤔As this is an internal SF object, it seems to be odd to show this as an error for us….The validation log on this object gives also the following information:Error message: Invalid column name 'verified'.Error number: 207Severity: 16State: 1Procedure: val_unverified_transl_engError line: 46For us this seems to be an issue in the SF….but maybe someone has an i
Hi i have a prefilter on some of my tables.What syntax do i use to toggle them on and off when calling the api of that table? e.g.{{baseUrl}}/employee?$prefilter=only_active_employeesHow to deactivate the only active employees prefilter?
Hi, Does anyone know how to change the default font of a RichText control in Devexpress? I have a html variable bound to it from my datasource, but instead of going for the default font set for the whole document it's presenting the data in TImes New Roman. Html variable bound to itAdvies is in Times New RomanI've found multiple custom scripts that change the font at runtime in some very old DevExpress support threads on their community, but those scripts make use of a library called RichEditDocumentServer. That library is nowhere to be found in the version of DevExpress that's available to us.Maybe there's a way to change the font of an HTML field before we feed it to DevExpress? I've seen this solution: but I don't necessarily want to change the font in the HTML editor or the column itself in Universal.Thanks!
I noticed I can add the same icon multiple times into the icons manager in the SF How is this intended?I can imagine that it is by design where multiple items that use the same icon all have a seperate icon in the icon manager to easily change the icon and reflect that change automagically.ORWe want all used icons in the icon manager once and when we want to change the icon for a specific item we change it thru to a different icon id.In the last situation I don't think duplicates should be allowed (filename or name )?
Azure files as a storage type now requires a username/SAS (Shared Access Signature) token combination instead of a username/password combination. The SAS token is required for all new Azure file storage configurations. Existing configurations have not been altered. However, if you clear the username/password for an existing configuration, the password field will be hidden, and the SAS token will become mandatory. I've tried configuring this, however it constantly fails since the SAS-token instantly gets removed when I add it to the SF application in IAM.
Hi, Hope you have a great day.How to include image to be show in the email body. Now trying to use the SMTP connector, but actually after some search and testing, the images should be included as attachments and then refered by id inside the html in the email body.Note: the images we need to show is acually stored in the sql server DB, so it is in the varbinary format.I have tried to include the image as Base64 in the htmle body, but also not showing. so the qestion is how to acheive that in SF.Loosking forward to hearing from you.ThanksAli
The Full Model screen seems to be no longer available since release 2023.1.Is there any reason for this?
Hi, does someone has experience with putting a QR code for an ideal payment link on an invoice.And is this somebody willing to share his/her experience. Thanks to year from you.
Coming from a ticket out of TMS: There are a lot of additional (i.e.search order) indexes generated by the SF that are either barely used or never used at all.These indexes have to be maintained when updating, adding or deleting a record which eventually cause a performance penaltyWe have 2 questions:Why and under what circumstances are these indexes generated Are they optional and how can we set this up that they are not generated at all?If this will cause an idea, please move this post into the right section on this portal.rgds Ricky
Hi,In the Windows it is possible to change the filter condition of a filter form in the GUI for example from ‘equal to’ to ‘smaller than’ etc. In Universal this can be set in the subject, however in the GUI itself this seems to be uneditable. Is there some way the user can choose it’s own filter condition like in the Windows GUI? If not, when will this become available?Kind regards,Allard
I have a cube view that shows numeric values as a dimension (2 dec) with the number of occurences as value. In the pivot table the values are shown as 2 decimals. In the chart it shows more decimals, even when the number of decimals is determined in SQL (cast .. as numeric(11, 2)). Is there a way to change this behaviour? Is it possible to reduce the initial scale?
Hi all,I am using Azure SQL (not the managed instance!) and run in the problem of all dates being UTC. Ofcourse I want to see the dates as if they are in my timezone (UTC+1) Have any of you handled with this before? And if so what solution did you use?I'm really curious on the different approaches.
Hi. We have quite an extensive flow and I noticed that after the initial task (start flow), it sometimes tasks some seconds to get to the next step. However there is no indication in the Universal that the flow is running. Is there a way to get a visual indication that there is an active flow and the user should wait for it?
For our application we what to show actions and messages in HTML. When a message is to long we want to collapse it and give the user the possibility to unfold it manually by clicking on it (see image) and therefore we added some javascript to the HTML. I have tested this in a form and in a cardlist but it seems the script gets filtered out. Also tested this with a preview-screentype as mentioned in this topic but it seems this is not supported in Universal.Is there a way to achieve this in Universal?
Hi,I’ve created a task where a user can select and a shift_id. A process flow opens a view. In this view I want to show only records with selected date and shift_id. In the where-clause this doesn’t work for some reasons. Do I need to set [parameters]? I now open an empty view, and tinkering with the filter-settings.. but either it’s all or nothing so far. Any tips on the matter? Alexander
When selecting a control with content type ‘data’ the control in the universal GUI has a white background. This is for example not nice when viewing the GUI in dark modeGUI versie2022.2.17.0.0GUI uitgebracht op09-12-2022Platform versie2022.2
Due to performance reasons, we have created some views on top of some main tables and linked them to the original table.From the grid (view) we show in the detail screen the form of the table itself.But then the add button is disabled.For the table itself the Add options are enabled in the subject settings.Also in the layout procedure we don't manipulate the @add_button_type and it is parsed with value 0I think this is because of the 1:1 relation between the gridview and the table itself.How to enable the default Add button?
hi,We have a table that needs some (say 10+) extra fields to display in a list, mostly calculated fields, some fields from a related detail (like address, pc and city from the same record).I could make this with calculation type expression and get this data, but is this gonna give performance problems? And I need to query specific tables more than twice (address, pc, city)So another option is to switch the table into a view, and get all the wanted data in a complex view. But there I see far more problems recreating the references to other tables and all tasks referring to data in this table as it is an important source table in the solution.There must be something I overlooked or don’t know about in Thinkwise, how can I solve this properly? Any thoughts?
I've tried to configure our production environment to only use Azure AD login. Therefore I disabled the local login, however it still works. Indicium does not actually hide the button. Is there some other setting I need to change as well? https://docs.thinkwisesoftware.com/docs/2022/iam_dev/openid#disable-signing-in-with-a-local-account
I have a question regarding the (error)logs from indicium and indicium legacy. It is really easy to look into the indicium logs via the HTMLpage: However, the error logs for Legacy are not available in the same way. Is it possible for TW to create a link via the HTMLpage? (TW_att_1 and TW_att_2)Also, how can we enable the logs on the legacy server? (TW_att_3) For us it is pretty complicated to access the windows logs and only 2 people are able to access it. The most errors for us happen on Legacy, so we want to be able to see those logs easily instead of using the windows logs. Kind regards, Loes
I added the extended property ShowTitleActiveChart=Yes, to show the title in the chart. Is there a way to set the used font size (theme)? It also seems that it's not only showing the title but also the name of the application. Can we avoid this?
Hi,I have a table with multiple details and want to use auto save and auto edit in the main screen and the details. So I set auto edit and auto save on in the SF. But some strange things happend when I switch between the screens. As showed in the GIF So it looked like that the column not save if you switch to a detail.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.