Questions, discussions, news and updates regarding the Thinkwise Platform.
Recently active
We like to automatically create users in IAM based on data in our custom application in that very IAM. It is intended to do this in a stored procedure which is involved in an automated process, started by a scheduled flow. This does not work. The error not_authorized_usr_admin is logged in the indicium log when trying to insert User records into the IAM database.It seems that the pooluser somehow does not have permissions to insert records in these IAM tables. We did some extra tests, which resulted in the observations that the code that creates the User records in IAM works fine in the situation when it is executed in Azure Studio in the same circumstances, even with the same authentication (being the pool user). This seems to indicate that the problem is somehow more complex. Can you please help us out in this matter?
Hello!What is the correct way to write the format of a header in SF? I have tried as example the way explained on this link: https://docs.thinkwisesoftware.com/docs/sf/process_flows#enable-the-message-protocol-independent-web-service , but it didn't worked for me.Thank you!
Hello, I want to make some of the fields, which they are private, to be shown something like this: ******ing.Is there a possibility for that? Thank you
Hi, When I have a table Activity with a connecting table to Item. This is the table Activity_item. Since I can connect several items to several activities. The connection table has 2 columns, activity_id and item_id, both the pk. The end user however would like to see more data from the item_table weight, owner, position, etc. Currently we can one get this data by creating a view from the connection table, join the tables and show all data needed. This is quite unpractical. What other ways would be possible to solve this, since connecting tables will (almost) always need more data from the other tables. I do not want to save duplicate data of course.. Thanks! Blommetje
I have a scheduled sysrem flow (Check_Machine_JobsRunn) that runs every 5 seconds.My sysytem flow check if there are any changes data on the machine and stores them on the database.I get data from my external resource till 31/11/23 alt 01:34Than it seems that, Indicium stops and restarts (i don’t know the reason) and kills the old process flows and create a ne ones (maybe with a new id).I see this on indicum logs: 2023-11-30T01:40:36.4418807+01:00 [WRN] No persistent storage location for data protection is configured. The Encrypt and Decrypt process actions are disabled.See the Thinkwise documentation on how to configure data protection. (51a9e278)2023-11-30T01:40:36.9161048+01:00 [INF] Initiating startup license check (a070e428)2023-11-30T01:40:36.9238294+01:00 [INF] Reading license from IAM. (d4563d62)2023-11-30T01:40:36.9297918+01:00 [INF] License successfully read from IAM. (66b06fb5)2023-11-30T01:40:37.1040291+01:00 [INF] License refresh scheduled for 2023-12-05 09:34:26. (09
Is there any way to deviate from the default selected-row theme for a conditional layout so that the conditional colour is also visible at the selected line (especially important if only 1 record is present). SF Theme Conditional layout
In the documentation for the tenats, an example is shown for multiple applications (multiple Idiciums) linked to a single data base is shown. Where each application has there own tenantsURL: https://docs.thinkwisesoftware.com/docs/iam/tenants We have created two applications, one for the operations and one for requesting data through the API.Where each applications has there own tenants, with different names.Now if we want to apply user rights to database, we get the following error message;“Could not apply rights for the application because there are multiple tenants assigned to the application” I can't find what I'm doing wrong in this instance.Can someone explain what I have to change, in order to setup the two application correctly, that I can apply the rights to the database.
The error pop up in devexpress is too small. When you get an error, for example when your query is invalid while managing queries, a pop up will appear with the error message. The text will, in this case, first show the query and always put the actual error information at the end of the text, however the query text is often too long to fit on the screen.The first image shows an example where the error information is only just visible and the second image shows an example of a longer query where the error information is not visible. It would be useful if there was a way to show the entire message, for example: Being able to drag to make the pupup bigger or being able to click on "more" which automaticly makes the popup larger. A quick easy fix could be to at least show the error information first in the message and then the entire query.Is there a way we can make the entire error message visible? Image 1 Image 2: error message is not visible
For the deployment of a new Windows GUI, does it matter whether you choose the TSF_ClickStarter or the TSF_dotNET .exe?
So we have this fancy way of letting our customers upload documents into our application. We then try to show them a preview when possible in the preview component. If said preview is not possible to generate a message will appear according to the documentation: “If a preview cannot be generated for a file, the preview component will state 'No preview is available'.”Now things do get hairy sometimes – when a “.msg” is uploaded, there is currently no way to determine what kind of file this is, it can be an email, an appointment, a note or any other kind of thing. When you are familiar with the msg extension, you probably are aware that this can be any kind of Outlook item. Most of the less tech savvy users are actually not that familiar with this phenomenon.When the current preview component is provided with anything other than an msg file that is actually an email, the preview component will either crash in the foreground(Windows GUI – up until latest version (2023.3.11))or show nothin
Hi, I want to hide the default null value of a combo element without setting it a default value type.Basically I want to hide the first empty row of a combo element that contains elements. Kind regards,Paul
Does anyone have experience with printing SSCC barcodes (GS1-128) on a SSRS report?Font Code128 doesn't seem to work for this type of barcode. How can this be resolved?I'm trying to get an output (Pallet Label) like below:
Hi, I have a subroutine ‘delete_project’. When I call this, it deletes the project. When a record has Referential Integrity and ‘No Action’, Indicium nicely respond with a base64 encoded message that it ‘ can’t delete due to Related <tablename>’ . So far, all good. However, when I don’t want to delete the project because it has for example a [status] = ‘active’ - so deleting is not allowed. In the gui we can display a message. Or with importing some data from an API, at the end we show a success/failure message; perhaps with a Process flow. Is it possible - and if so, how - to pass these messages through Indicium? If a user connects with the end-point, it will make a lot more sense then a 422 - unprocessable entity when something is not allowed, or processed correctly.Thanks! Blommetje
We made a track and trace Webservice (= Message Independent Protocol system flow) for external usehttps://xxx.xxxxxxxxx.com/indicium/open/sf/api/public_track_traceIt works fine as POST request within Postman and I asume that it must be possible to use the API when running it in website in a browser.Now the developer of our public website wants to implement the Webservice but runs into CORS related errors and it looks like we have to make some adjustment at our side.Any ideas on what must be done in the setup of indicium to let it work? Or do we have to add something special in the response headers?
Hi,I would like to know if it is possible to cancel editing an auto-edit/auto-save form using a task.The situation is next: we have several actions a user can perform within a form, based on table tasks like, submit, print and cancel. We have choosen to place these buttons at the right bottom corner of the form. The default behaviour of the tasks is that Thinkwise will perform a save and with that validate if all mandatory fields have a value. If not, a message will be shown and the task will not be executed. For the submit and print tasks this is the way to go. For cancel however, the save and mandatory field validation should not occur. Any empty mandatory field will show the exception message and prevent the task from executing.I know it is possible to first use the generic cancel button and then the task button, but this needs two actions by the end-user instead of one.Is there a way for a task to bypass the mandatory field validation and be executed regardless of the subjects stat
hi,As an ISV we want our customers to set a folder to import files, this folder can be changed to specific sub-folders, but is always on a server, and Indicium has access to it.With the current (2022.2) List folder, we have to set a storage location but we cannot change this location from the client application. After getting the filenames, we can use the Read File (non-file storage) to read the files and process them further.How can we set a dynamic folder to read these files?
I have an issue where i have a procesflow that opens a document which then filters on a specific activity id. The activity has more that 100 items connected to it. Currently i have this as my configuration: This gives me 1 page but limits me to 100 records. if i set the maximum to 300 for example i would be able to get all the records(items) but not if another activity has 600 items.Is there a solution for this?
Hi, I'm fresh, sorry for any mistakes.Usecase: Users want to column sort respective tables on date, this doesnt work as we intended. (Screenshot below post)What doesnt work? Datenotation(timezone) in the date domain (widely used) is set to local (Netherlands) but the grid still shows a MM/DD/YYYY Notation. Sorting doesnt seem to work as intended. It drops a random 2022 row between a 2023 rows. What have I tried?Tried to set the datenotation(timezone) to ‘Show as stored’ and back to ‘Local’. Tried looking for hidden sorts on the grid, there isnt any. Checked if the date is stored as something different than a date (like string, int, etc)When is my problem solved?The moment sorting works again as intended, even better would be a small explanation why it does(n't) work. Thanks in advance.
Hi, I've written a SQL statement that checks if value A > value B. If thats false Value A gets a reset and the system throws a tfs_msg. The code is ‘copied’ from an already working functioning pop up message, however it work significantly different. Does anyone know the source of this issue and how I can solve/ troubleshoot it?Thanks in advance. Error (code supplied in screenshot): Expected result (same code construction, different properties, code supplied in screenshot): Code: Upper code is screenshot 2, error code is screenshot 1.
I can’t seem to find a solution to my problem so I hope anyone of you knows an answer to this. So the situation is this: I have a view/cube were I have certain parameters( Hal, year, quarter and some results) (see image)In this I use the first row to display the totals of those 4 quarters, which I calculate in my sql environment. (Because I was unable to do so in Thinkwise, seeing as he kept adding all those percentages instead of calculating the percentage of said total, even with a calculated field where I specifically told him to use the results in those totals to calculate it)So this question might be a multiple one. The first being, isn’t there a way to do this in thinkwise so that my results are what they should be? So in this case 0.06% instead of 0.25 which I get now. (Because I need to have this resolved before I can use whatever answer you give me on the next question)And the second question is if I replace my total row with a running total row calculated in thinkwise how can
Hello, I have created a basic database image upload functionality and I want to know if there is a possibility to switch from the database blob to azure blob storage depending on the image size. I saw that on the file storage locations you can pre-define a max size in MB.What I want is to have that set up to a limit and if my picture exceed the limit, I want it to be automatically saved in azure blob and not in the database. For example if I set up the file storage location to my database and I set up the limit on 5 MB and I try to upload a picture bigger than that I want the picture to be sent in azure blob storage and not in database.For azure I have also set up a file storage location and I don't know if I can make them work together.
If you use multiple monitors, one has to be the primary (in windows). It can be quite annoying to have popups open on the primary monitor, while the application is open on a secondary monitor. Also it doesn’t seem to be consistent. A task will open on the same monitor regardless if its primary or another, but a popup screen or things like location will open on the primary monitor.Is there any way to steer/influence this behaviour? Without messing with the primary display setting in windows.We are using the windows gui.
Hi,Is it possible to show a badge on the menu group? In Universal the groups are by default collapsed, so people miss that there are important notifications waiting for them, unless they actively open the menu group. Is it possible to show the badge on the group as well?
Extended filter is empty, where in a simular view, it is available. Why does it not show any options?
Hi all,I deployed an upgrade to an end application. Ever since, some of the reports (Crystal Reports) do not work anymore on users’ systems. The platform version has remained stable.During development and while testing no problems occurred. It turns out that having SQLServer Management Studio installed is required for a working report.Without the management studio, Crystal Reports refuses to connect to the database.I imagine that installing the management studio provides additional database drivers, without which the CR runtime is not able to connect to the database.I have not been able to figure out which installable drivers the reports depend on, where to find such a driver, and why this is a problem all of a sudden.One thing could be that development is done against a more recent SQLServer version, as we do not have access to post end-of-life databases for development. (The situation is not being helped by running a zombie platform version, because of difficulties procuring an upgra
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.