Ask a question or have a conversation about the Thinkwise Platform
Recently active
Compared to other platforms, Thinkwise really excels in productivity. Especially the fact that creating a Data Model immediately results in a working Application is unparalleled! One of the current strategic priorities is to double down on this development speed of the Thinkwise Platform: we strive to make every Developer a mythical 10X Developer!There are a lot of angles we can work in order to achieve that goal. As a first, we want to fix unnecessary limitation in the Software Factory (SF). This means we want to tackle those things for which you as Developer have to create workarounds to get functionality working the way you(r users) need it.There are a lot of great Ideas out there and of course we'll review the existing ones. But I would also like to call upon the Community to highlight which existing Ideas would be your priority and/or to create new Ideas related to eliminating SF workarounds (please keep it to this scope in this topic).Could you please:Reply with Ideas that would
A customer has migrated to Windows Server 2016 (64 bit) and now our reports (Crystal Reports) don't start anymore. The error message is: The type initializer for 'CrystalDecisions.CrystalReports.Engine.ReportDocument' threw an exception The Thinkwise applicatie that the customer is working with has been developed with TSF 2017.1. The version Windows GUI is 2018.1.17. The SAP Crystal Reports runtime engine for .NET framework (64 bit) is 13.0.13.1597. I have two questions: 1. What causes this error? 2. What determines which version of the SAP Crystal Reports runtime enige I should install? Could anyone help me out here?
/-This is more of a SQL question-/For the project I work on I'm in charge of realizing functionality to import large amounts of Product data (ASCII format / .txt file data). The database I work with is placed in a environment where multiple companies work on the same database. In the application, they only see their own data. For example, if 30 companies use the database and all have a pool of 1 million Products, then the 'Product’ table will have 30 million records in total but will only see their own 1 million products.The data that I will import consists possibly over a million records and will be inserted into the single ‘Product’ table. What I'm worried about is that inserting 1 million products in one go will take a very long time, so I want to look at possible ways to accelerate this process and making sure that importing big files does not take hours.I have read about removing indexes, parallel processes and such to speed up the process but I'm not fully convinced it would be t
Hello all,Does anyone have an example of an t-sql request against a REST API with a Multidata/Form? We already call several REST APIs, but not with Multidata/form. Below is a setup (which does not work). The API converts a PDF document into fields in json format. It contains 2 fields that must be included:name (name of the document) document (base64 encoded string)Below is a first attempt, but it does not work :-). Thanks in advance for the reactions.declare @response table (txt nvarchar(max)); declare @object int , @url_endpoint nvarchar(200) , @response_format nvarchar(5) , @request nvarchar(250) , @json nvarchar(max) , @address address , @body varchar(max) , @status int , @d
Hi there,we're running into a azure application gateway issue. We have an application where we can trigger a task on a record. In this task we upload an asset. The issue is that we can only upload files that are smaller then 128Kb. Between us and the application in a Azure Application Gateway. This application gateway has a policy that enables inspection of the request body. The MAX REQUEST BODY SIZE is set to 128Kb. The MAX FILE UPLOAD SIZE is set to 100Mb.Is seems that since Universal uses odata to communicate to indicium the file upload is parsed into the request body and thereby is limited to 128Kb in size. The clients IT department forwarded the following documentation that indicates the max request body size limit is 2Mb on the WAF.The other solution they suggested was changing the content-type to multipart/form-data. That way the file upload size limit of 100Mb would be applied. As we're using universal this isn't possible.Any other suggestions because needing to limit the file
Hello everyone,We're experimenting with the API functionality and its OData query possibilities. We have a situation that we can't seem to get "right" though. Let's consider the following situation:Table "car"Table "driver"Table "car_driver"Car_driver obviously is the linking table between car and driver. To query that, we need to "expand" the relation, as explained in the documentation. So, we can do like this:https://our-fabulous.thinkwise-app.net/indicium/iam/our-app-id/car?$expand=detail_ref_car_car_driverto obtain the car and all ID's of the drivers, orhttps://our-fabulous.thinkwise-app.net/indicium/iam/our-app-id/driver?$expand=detail_ref_driver_car_driverto obtain a driver and all the car ID's he or she drives. Both queries can use an addition filter and other goodies.So, how do we "expand" our data model, so that it gives a car with its drivers in one go, or all drivers with their cars in one go? We can expand one level, but not beyond that. What do we need to do, to hop over a
I'm trying to get a response from a webservice, located outside our organisation. The site is secure (https), but other than that, the piece of code (dbo.make_soap_http_request in this case) is doing the trick on an internal webservice (http, not secure, Navision webservice).The parameters (url, username, password etc etc) used when executing the instruction below work fine when executed from my or another desktop (no special certificates installed by our IT department) when using SOAP-UI for example).Parameter @http_uri below contains an URL to a secure (https) site. exec dbo.make_soap_http_request @http_uri , @http_request_method , @soap_request_body , 'http://gateway.integration.volvo.com/soap/1_0/WsMqServices/processMessageRequest' , @username , @password
When executing a task for a selection of rows, the user interface first executes the context procedure for every single row to check if the user is allowed to execute the task for that row, and then executes the task for each permitted row. This can be quite time consuming, especially for web clients where the progress is also reported back to the client.To speed up multirow task execution, a new feature has been developed to execute tasks for a selection of rows.To enable multirow execution for a task:Add an XML-typed parameter to the task Make sure Popup for each row is switched off Set the MultiselectParameterID extended property with the name of the parameterWith multirow execution enabled for a task, when the user interface executes the task, the specified XML parameter is filled with the parameter values for all rows. Even if only one row is selected.The parameter is only filled when the task is executed. The XML is therefore not visible in the popup or available in the default a
Hi. I have been fiddling around with getting a token for the Microsoft Graph API. I want to read an email box from a fixed user and use it in an application. So I went to the AD portal, registered the App et cetera. When I use the v2 oauth URI's then I get an error : "invalid_requestAADSTS90014: The required field 'scope' is missing from the credential. Ensure that you have all the necessary parameters for the login request. When I use the v1 oath URI's then I get a token, but whenever I try to request a resource I always get the message: "message": "Access token validation failure. Invalid audience." I really don't understand what is the solution. How should I set this up?
With the report mailer function we export a Crystal Reports report to an Excel document. This doesn’t automatically set the column width correctly (see image below). Is it possible to change this?
When creating a domain you must choose the data type. In this case I want to create a Global Unique Identifier (GUID). Clicking on the data type lookup I am able to see more details for each data type (figure sorted by type).In this list there are two Data types of Type “Guid”.First question is what is the difference between these Data types?Also what is the meaning of each attribute? And in particular does Calculated mean that columns of this type will not be stored in the database?
How to solve this this error message? Invalid signature
We created a report in Crystal Reports which we want to export to xlsx format and not to xls format. Is this possible? We want to do this because after generating several Excel files using the Thinkwise reporting Service we want to combine them as separate worksheets in one excel file. The component we use for this needs to have xlsx and not xls.
I created a unique index and I deployed my project. When I try to delete this index I am getting“An explicit DROP INDEX is not allowed on index ‘ sales_person.unique_sales_person’ . It is being used for FOREING KEY constraint enforcement.”error message.I tried to clean install but it didn’t work. It is in software factory version 2022.1How can I solve this?
Our users are logged in through various methods. Some have managed systems, others log in via RDP. Sometimes a user has their files synced with Onedrive, others have a profile folder on a shared drive via redirection. This leads to reports with export to pdf setting being saved in various locations.For a process flow we were able to program one of these file paths by putting a username variable as part of the path but this renders the flow unusable for quite a few of our users. The flow uses a move file action but it often can't find the exported pdf file. Therefor we need a more generic approach.What folder does the export to pdf option use internally to determine where to save a file? I've tried %USERPROFILE%\Documents but already in my own case this leads me to the wrong folder.
I’ve maganged to setup the connection to the Exact Online API from postman.Now I try to setup the connection from the SF but we running into an invalid_request error as a result.I’ve used the same input variables and keys, so at the moment I’ve not a clue why this result is happening: Has anybody in the community succesfully connected to the Exact Online API.
What is the use of the status for requirements? At this point the status of a requirement is always new and does not change during the whole project. It would be nice to have statusses like: In progress - requirement is being worked on. Approved - The key stakeholder has agreed to the requirement and the developer has agreed that it is possible to create Implemented - Code has been designed and is ready for review Verified - The requirement is tested and is functioning correctly Deleted - An approved requirement is deleted. An explanation is needed of why and by whom the decision was made to delete it. Rejected - The requirement is not approved. The why and by whom it has been rejected is relevant. Deprecated - The requirement is no longer in use and has been replaced by a new requirement. It should also be possible to filter out all of the requirements based upon the status. This way you can always refer to a certain requirement that has been deleted or r
Does anybody know a good way to catch and prevent the error, when a file for some reason is locked for reading and processing? Executing API 'CreateFile' failed with error number 32. Error code 32 is ERROR_SHARING_VIOLATION . So the mailer cannot read the attachment file because something else is reading it. Besides the fact that you cannot really reproduce it until it happens, I cannot really find a way to catch this error upfront. I am using the file_exists function to check upfront if all documents exists, and even though all attachments can be found, at the time of sending the mail at occasions you get this error. The only solution I can think of now is to set the AccountRetryAttempts to 2 times to tackle this problem. But it's not the fanciest solution, anyone has experiences with this?
I have the web gui on an Azure App Service. But I notice the “Logs” folder isn't created, and if it exists the files aren't placed there. I use this ini settings: Server = server.database.windows.netDatabase = iam-databaseRuntimeConfiguration = RDBMS = SQLSERVERMetasource = IAMLanguage = engAuthentication = rdbmsExecutionmode = developerCSVLogging = TrueLogToFile = Yes When I copy the GUI folder with the same ini to a local IIS application it does create the folder and a Debug.log on start-up. Do I have to do a bit more on Azure, or am I looking at a bug?
Crystal Reports asks for user credentials after update of platform and server migration. Why? How to solve? There is no logging in the debugger. This is the situation: all on windows, no web/mobile start with platform 2018.1 on server A, named DB01 copy all to server B, named DB02 upgrade platform on server B to 2020.1 rename server A to DB_decomissioned rename server B to DB01 Included in the platform upgrade is the switch to another Crystal Clear runtime. After performing all steps the application is running fine. Reports though come up with a login screen where it used not necessary to login. Tried login combinations, at least: user account, integrated security / domain logon user account, password administrator account, integrated security / domain logon administrator account, password Neither user has trouble accessing the application or querying the underlying data used in the reports via the SQLManagement studio. The server is not a combined domain controller, as in the other
I'm trying to convert a XML document with binary data to a zip-file via a self developed .NET Core 2.1 Web API using a process flow with a http connector. It's a follow up on this topic: https://community.thinkwisesoftware.com/deployment-12/moving-to-azure-sql-database-azure-file-storage-713#post2018 When testing the POST call via Postman and a simple .NET console application I receive the result as expected. When using the process flow using a http connector, it returns an error in the SF-Debugger: The remote server returned an error: (411) Length Required. This could indicate the Content-Length header must be applied, so I did: (Please note this is a fixed length, because the Content is also fixed value for now.) Unfortunately this results in an error: code:The 'Content-Length' header must be modified using the appropriate property or method.Parameter name: name at System.Net.WebHeaderCollection.ThrowOnRestrictedHeader(String headerName) at System.Net.WebHeaderCollection.Ad
How to set up an API connection using the OAuth 2.0 with Exact Online?This resource was a good starting point.I can’t find a way to use a valid “redirect URI” in the SF.Any suggestions?
This is an Archived topic. The solution is available in the Thinkstore inside the Software Factory.GoalMany application have functionality for importing or exporting data in XML format. Sometimes you will get an error about an illegal XML character:XML parsing: line 1, character 2967663, illegal xml characterAnd then you will have to try to find that character, which is very hard. This solution can help you out.SolutionThis solution creates a stored procedure search_illegal_xml_characters which searches your entire database for illegal XML characters. It is also possible to search in one specific table.The procedures uses a function, remove_illegal_characters_for_xml, which is also created in this solution. Important: this function does NOT remove illegal characters from your database. It only removes those characters from a string.Dynamic model add_search_illegal_xml_charactersThis dynamic model code creates stored procedure search_illegal_xml_characters and function remove_illegal_ch
This is an Archived topic. The solution is available in the Thinkstore inside the Software Factory.GoalBased on a customer story.Every day at 06:45 a procedure runs for the customer and during that procedure, errors can occur. These errors are recorded inside the application and viewed by one particular user. This user only opens the application to look at these errors. If there are no errors at all, the user still has to look inside the application to find out. It would be more handy if the user gets an e-mail with a Report of all the errors. SolutionBy using the System Flow functionality, we can autonomously let Indicium take care of generating a Report and sending it to the user by e-mail.In this example I will show you what is needed to achieve this.Prerequisites:Indicium (Universal) - hereafter called Indicium Application in IAM SMTP server for sending the e-mail - this example uses a free SMTP server by sendinblueChaptersCreate a View in the Software Factory Create a DevExpress R
Hey all, I am getting this error when i am trying to add a record in a view any idea what this means?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.