Crystal Report Asking for Login Credentials

  • 29 April 2020
  • 2 replies

Crystal Reports asks for user credentials after update of platform and server migration. Why? How to solve?


There is no logging in the debugger.

This is the situation:

  • all on windows, no web/mobile
  • start with platform 2018.1 on server A, named DB01
  • copy all to server B, named DB02
  • upgrade platform on server B to 2020.1
  • rename server A to DB_decomissioned
  • rename server B to DB01

Included in the platform upgrade is the switch to another Crystal Clear runtime.

After performing all steps the application is running fine.

Reports though come up with a login screen where it used not necessary to login. Tried login combinations, at least:

  • user account, integrated security / domain logon
  • user account, password
  • administrator account, integrated security / domain logon
  • administrator account, password

Neither user has trouble accessing the application or querying the underlying data used in the reports via the SQLManagement studio.

The server is not a combined domain controller, as in the other question on this site.

The internet has answers, I have not yet read, let alone tried, all of them. There are no development tools other than Internet Explorer and SQL Management studio available on the deployment environment, nor is there access from the development environment (and tools) to the deployment environment.

The firewall configuration is said to be identical to the old situation. I have no access to it, and very limited options to troubleshoot issues concerning connectivity. Could it be an issue here?

What makes the Crystal Reports logon ‘tick’? How does it break?

This used not to appear. Now it does. It does not work.
It says: “Login failed. Give it another try.” It does not work.



Best answer by Boudewijn 1 May 2020, 08:44

View original

2 replies

Userlevel 6
Badge +5

Hi Boudewijn,

This will require some further investigation, but it sounds like a DNS cache problem. The client may have DB01 cached to point to the server A on the client running the report.

The symptom you describe would occur when the DNS cache is outdated and database server A is still running but the database is no longer accessible on this decommissioned server.

This issue was solved by enabling TLS 1.2 on the server:

  • Enable under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\