Ask a question or have a conversation about the Thinkwise Platform
Recently active
Has anyone found a solution to show images, which are stored in Azure file storage, in a SSRS report?SSRS = SQL Server Reporting Services
Hi All,I have a question about using subreports in SQL Server Reporting Services (SSRS) in Thinkwise.Currently for testing I am using Microsoft Visual Studio (using Report Server Project) to make a simple main report with a subreport.What I did was I made 2 reports (see Figure 1). First the MainReport.rdl and second the SubReport.rdl Then in the MainReport insert subreport item then right-click on subreport item then Subreport properties then under "Use this report as a subreport:" I select the subreport file I made earlier named SubReport.In Software Factory in Reports I'm using for Report type "SSRS (Local)" then in File I select the MainReport.rdl. When I'm opening the report in application I get an error (see Figure 2) saying that subreport could not be found at specified location....What I did I moved the subreport to the specified location given in the error and renamed the file from .rdl to .rdlc and got the expected result information on the subreport.My questions:Is that the w
We have been live in Production with the Universal GUI since November 2020. During the past few years the functionality of the Universal GUI has been massively improved by Thinkwise. In the meantime we as Thinkwise customer have learned a lot from our end users regarding their User Experience with the Universal GUI. Based on our experience, we believe the UX can and should be improved a lot by Thinkwise!And since @Jasper promised in the Release Event 2023.1 that Community Ideas will be prioritized more, I would like to use this post to list the most important UX improvements and gather a crowd of votes from all of you at the Community!I really expect the below Ideas to improve the UX for all Thinkwise customers' end users. Please vote on each Idea listed below that you believe serves your needs too and add a comment below to keep the topic ‘alive’!And since this list is nowhere near exhaustive, feel free to add additional Ideas in the comments below! NOTE: this is topic is specifically
Hi , I am getting below error , its not the issue with reference as stated in This is is only coming in the acceptance environment.The same set of data used in developement environment works well.Can you please let me know what I am missing?
I'm trying to use the Indicium OData API via a .NET Core 3.0 console application. I receive an exception on inserting records, while the record is inserted in the database. I have no clue why. I'm not sure if this is an issue in the Indicium OData API or the .NET nuget package. For example I want to add a ‘server’ to the IAM database. By using a generated piece of code (see https://docs.microsoft.com/nl-nl/odata/client/basic-crud-operations) this is quite easy to set up; Add the indicium OData API via “Unchase OData Connected Service” Configure the metadata ($metadata.xml is the result of http://server/indicium/iam/iam/$metadata)With the following code you retrieve the ‘server’ table and insert a new record in to it: using SQLSERVER_IAM;using System;using System.Net;namespace IndiciumTest{ class Program { static void Main(string[] args) { var uri = new Uri("http://server/indicium/iam/iam"); var container = new Container(uri); container.Credentials = new NetworkCredential("userName", "p
Since some versions we have a problem with the Universal GUI after updating. The setting "requestFiltering removeServerHeader = true" in the web.config file causes a 500.19 HTTP error when starting the Universal GUI.If we remove the lines below from web.config, the problem is gone. <security> <requestFiltering removeServerHeader = "true" /> </security> The problem is also present with the most recent update.
Suddenly we had the following error (displayed as information?) in our webgui (2020.2.22) hosted on Azure:Error Report scripts were found in the application while the script execution is deniedI have absolutely no clue by what this error is caused. We haven't done any application or webgui updates. I’ve restarted the app service and the error disappeared.We have a DevExpress report with a before print event which is probably causing this error.Anyone familiar with this? I want to know what is causing this error.
Hi, everyone!If you've been keeping a close eye on the news recently, you might have noticed that AI and Large Language Models (LLMs) such as ChatGPT are making big waves. They're popping up everywhere, becoming integral parts of countless processes and applications, and for a good reason. The potential of AI is immense, and here at Incentro, we're beyond excited to explore it!In our journey to explore the power of AI, we've brainstormed countless ways to implement it within the Thinkwise platform. We've thought of various use cases, and today, we're excited to showcase one of them.Introducing TW-GPT, an application that uses the power of AI to take the Software Factory to new heights. This application incorporates a standout feature - the ability to autonomously generate descriptions for different entities within the Software Factory that currently lack descriptions.Control procedures and tables can sometimes be a mystery to those unfamiliar with them. They're crucial components of ou
Hello everyone,Because the new Exchange connector that is scheduled for the month November of this year will not give adequate possibilities for our client, we're trying our luck with Microsoft Graph. We created a call and made it fit our needs using Postman.We configured and use all the right credentials (client ID, tenant ID and client secret) for token generation. Actually, we created a call for getting data, and one for patching data. The call types are, of course, get and patch respectively. All calls are successful, and perform as expected, using Postman.Next, we went to our Software Factory, to make Thinkwise perform the same calls. Using a process flow, we make the proper call, the same as we did using Postman.We get a correct token in Thinkwise. When we copy this token from the debugger, and check it with jwt.ms, we get a valid token. In fact, when we use this token in Postman to make calls, it works perfectly. So, token generation works properly.However, the calls that work i
This morning when I tried to reach out an application using the OpenID provider, Indicium 2021.1.16 - hosted on Azure - suddenly crashed. The first message I received was:The specified CGI application encountered an error and the server terminated the process.I refreshed the browser and then I got the following error:HTTP Error 502.5 - ANCM Out-Of-Process Startup FailureCommon solutions to this issue:The application process failed to startThe application process started but then stoppedThe application process started but failed to listen on the configured portTroubleshooting steps:Check the system event log for error messagesEnable logging the application process' stdout messagesAttach a debugger to the application process and inspectFor more information visit: https://go.microsoft.com/fwlink/?LinkID=808681Then I refreshed again and it worked again.In the logs I can only find the following lines which probably have to do something with it:2021-03-09T08:25:54.2547150+00:00 [FTL] Unable
This is an Archived topic. The solution is available in the Thinkstore inside the Software Factory.GoalWhen you have system versioned tables in your database, SQL Server logs all changes made to the data in those tables. This solution makes this logging data available for the user. This can look like this: SolutionThe solution in this topic creates views on all system-versioned tables. These views give the user access to the logging data. Also, all of these views get conditional layouts in the Software Factory. These conditional layouts give fields with changed values a color, which makes it easier to analyze the data.Dynamic model meta_view_historyThis code create a view definition for every system versioned table, along with conditional layouts to point out changed data.When you add this code to the dynamic model, you have to change a few values first:@screen_type_id Your desired screen type: You can keep this null, or change the value.@original_date_column Na
I'm trying to move our product to the Cloud using this blog post: https://community.thinkwisesoftware.com/blogs-21/to-the-cloud-leveraging-microsoft-azure-paas-155. I'm facing some difficulties regarding the differences between an on-premise environment (SQL Server and a file system) and Azure (Azure SQL Database and Azure File Storage). To start with, it's the difference in handling files. In the on-premise setting I'm able to upload files and read them using methods in SQL Server like xp_DirTree for reading a directory, and openrowset / bulk insert reading the contents of the file. In an Azure environment this isn't possible. Lets say the steps for the end user are currently as following: The user starts a task where it can upload a file using a 'File upload' control. This upload is bound to an Azure File Storage location, so it'll upload immediately. The user executes the task: The sql procedure of the task is called to process the uploaded file. In example the user uploads a
Related to the ZPL paragraph in this topic:In our current application (WIndows GUI) we address Zebra label printers by posting a ZPL file to the IP address of the printer. The printing is done by Indicium (running as a service) from an application server, the user just creates a record in a queue table when pressing ‘print'. The configured address syntax for the printer in our application is for example: http://192.168.1.240:9100. This bypasses any Windows printer driver (which is preferred).Now, we also need to offer the possibility to print ZPL files to a local Zebra printer; meaning a printer connected to a PC by USB, and using a Windows printer driver. This printer can be shared (UNC path) to make it accessible to Indicium on the application server.That also means that two Windows printer drivers will be used; the printer driver on the application server and the printer driver on the local PC with the printer. Although this scenario is not preferred (because it is easy to have in
I've created a API-routine to collect article-items. The purpose is to use these items to refresh webshop-information by a third party. The following problem occurs: when a description of an article is emptied in the ERP OData seems to skip the field in the output because it is NULL. The third party will not recieve any data so the description in the webshop stays filled. Is there a way to force NULL-fields to be in the API-output without using spaces oslt in empty fields where the third party has to coop with.
Since a last IAM Sync today our scheduled system flow won't be executed anymore. Last run was at 2.21: PM (UTC) today but the next run every 3 minutes will be updates, but the task won't be executed.We have both Indicium and Indicium Basic running against this IAM to support both Universal and Windows UI via Indicium.An IIS restart didn't fix the issue, nor a sync of the IAM did fix it.Running IAM 2021.1
We have a number of assemblies configured on the current development environment. These assemblies need to be passed on to every development/demo/customer/production environment. Last week we've added the assembly HttpConnector to our current development environment. This assembly was also needed in the multiple demo/customer/production environments. It appears that this assembly wasn't automatically created on the different environments. Whichresulted in errors in a customer/production environment. Besides the above assembly we also have more assemblies that need to be passed on to every environment: SQLTCPExhItemSender HttpConnector Newtonsoft.Json System_Runtime_Serialization Is it possible to configure these assemblies to be part of a deployment process? It also raises the following questions: How do we make the assemblies part of the deployment process and prevent manual work? How do we maintain the original .dll files? How can we apply newer versio
This is an Archived topic. The solution is available in the Thinkstore inside the Software Factory.GoalThe goal of this solution is to automatically add trace fields to all tables so the user can see who added the record or who made the last change. This solution adds these fields to a separate tab page on a form. This looks like this in the GUI: You can choose at what moment you want the fields to be filled: During editing or after saving the record.SolutionThe solution consists of code for Dynamic Model (for adding the fields) and two Control Procedures (for filling the fields). Depending on the moment you want the fields to be filled (during editing or after saving), you can choose either for a control procedure for defaults or for a control procedure for triggers.Dynamic model add_trace_columnsThis code adds trace columns to every table.The trace fields are: update_user update_date_time insert_user insert_date_time If you add the tag 'no_trace' to a table, no trace columns
Hi,When executing a process flow with an HTTP connector in it that does a POST request into IAM I get the following error:[ERR] Process action "connector_create_external_user_group" in process flow "create_external_user_in_iam" in application 97 threw an exception. (dedd009e) System.Net.WebException: The SSL connection could not be established, see inner exception. ---> System.Net.Http.HttpRequestException: The SSL connection could not be established, see inner exception. ---> System.Security.Authentication.AuthenticationException: Authentication failed because the remote party sent a TLS alert: 'HandshakeFailure'. ---> System.ComponentModel.Win32Exception (0x80090326): The message received was unexpected or badly formatted. --- End of inner exception stack trace ---The thing is that the same request / process flow works on our dev enviroment. This error occurs only in the test environment. Is it some kind of certificate issue?Both the app services (dev and test) are runnin
When I want to start my application as a domain user, I get the following message "Cannot open database "..._IAM" requested by the login. The login failed. Login failed for user 'DOMAIN\\user'." All the domain users work properly, only the users that has been set on "disabled" and later set back to "enabled" have the double backslashes. When I start SSMS i can normally logon to the databases. windows2012R2 SQL2008R2 Can anyone help me on this? Thanks in advance
For a certain task it’s required to query a system-versioned aka temporal table at a certain point in the past. Let’s call this table temporal_table for simplicity.Here’s an example query:select v.*from temporal_table for system_time as of '2021-2-27 14:59:46' vIn SQL Server Management Studio (SSMS) this runs in about 2 seconds for this particular table. Using this in a lengthy select statement with a bunch of joins also runs rather fast in SSMS as it takes about 10 seconds to finish.The problem happens when this code is used in a task in our end product. As soon as the for system_time flag is used in the SQL code the task goes from running 10 seconds to what’s basically forever. This is the same code used in SSMS, with the exact same datetime for testing purposes. (This date will be replaced by a parameter in a later stage as it needs to be dynamic.)I’ve tried to get around the issue with this alternative query:select v.*from temporal_table for system_time all vwhere '2021-2-27 1
Since the new version the generation process is done by Indicium. However, often this message is displayed; It usually disappears/appears a few times and the generation does not fail, but still, It does not look good to me. What is the cause of this message?Thanks!
This is going to be a lengthy post about the Resource Scheduler extender. Instead of making a couple of threads, I’ve bundled all questions we have regarding the resource scheduler into one. Extender properties Let’s start with the extender properties of the resource scheduler. In addition to the extensive amount of properties you’re presented with, the description of said properties leaves a lot to be desired. Most of the time there’s little to nothing added to make clear what a certain property really does or how to properly set up one. For example: As you can see the value type of the ‘Days’ property is Int. But if I, let’s say, enter 5 as a value and refresh my model I get the following warning. That leaves me with a lot of questions as to what format is acceptable in the value field. Another example of a description that raises more questions than answers is in the same custom scale subject. The Timespan format, it’s description and expected value type. Again, I’m no
I can no longer navigate to my local indicium instance. It's giving me a 500 error and the log shows this error: 2022-12-05T13:46:28.4343183+01:00 8000000b-0009-ff00-b63f-84710c7967bb [ERR] An unhandled exception occurred while processing the request. (ffba027a)System.InvalidOperationException: The MetadataAddress or Authority must use HTTPS unless disabled for development by setting RequireHttpsMetadata=false.Where do I set this setting? I can't find any documentation on this. Do I set it in the appsettings or web config? And in what section does this need to be added?
I have a procedure B that is called by procedure A.In Creation- Execute source code I do get warning: The module 'A' depends on the missing object 'B'. The module will still be created; however, it cannot run successfully until the object exists. I had changed the Generation order no. on procedure A to 99 and on B it is 100 (Functionality)but that did not do the trick.How can I fix this?
When in code review i want to compare code. Normally an external tool would open. My collegues work in Winmerge but the it policy changed and we now have to work in Kdiff3. Iver installed this tool on my computer but when i press the button in TSF it does not open but provides a message:Het systeem kan het opgegeven bestand niet vindenany idea how to fix this?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.