Questions, discussions, news and updates regarding the Thinkwise Platform.
Recently active
Hi all,We want to automate the deployment of our application with PowerShell.Calling ‘add_job_to_generate_definition’ with Postman works fine. However, when calling the API with a Powershell script, I get a 403 Forbidden error.Indicium is hosted on Azure. I use the same credentials as in Postman.Am I missing something?Thanks in advance!Kind regards,Rick
We have a TW application where the user basically works from one central list with transactions (shipments). Optimally this list should automatically refresh when records were added by a background process. However, it turned out when auto-refresh is enabled, not just this list form (SQL view) is refreshed but all forms on all controls in the entire application. So when the user is at that moment working in edit mode in another form of the same application and choosing a record from a dropdown list, this dropdown list closes automatically due to the refresh on the list form. Or when on another form a tree view is expanded, it will automatically collapse due to this background refresh. Very annoying and counter-productive.Is it possible to do this auto-refresh local on ONE FORM only, and not throughout the whole user session?
Hi, When creating a can set an auto increment for a PK column; However, I still need to write something in the Template to fill this column. It's not generated by the SF(or at least I don't see it). When I set this to for example a row_over value it is unique - but the seed/increment is ignored. When I select a fixed value (1) - the view PK is not unique and an error is thrown. Is this in any other way usable? I don't understand how this should/could work. Thanks, Blommetje
Hello,I have a question about the calendar when I have a domain configured as DATETIME2 with the following settings:Datetime2 domain config When the user is registered in IAM with language=English & Timezone=Etc/UTC, the first day of the week is sunday:language=English & Timezone=Etc/UTC When I change the language to Dutch in IAM for that specific user, the first day of the week changes to monday:language=Dutch & Timezone=Etc/UTC Now I have colleagues from the UK asking me to switch the calendar formatting such that they also have monday as the first day of the week, but this does not seem to be possible?When I google the formatting in the UK, I find that people from the UK often use Monday as the first day in the week in business settings. I am using GUI: 2024.3.13.0.0Is it possible to change the first day of the week?
I am working on a PowerShell script to automate the installation of our TW application, which is and will be running at dozens of customers.I encountered the following problem:When installing/updating the IAM database and there's nothing to do, twdeployer just returns a warning (OK) - although it seems that a hotfix is always applied even when applied before.When installing/updating the APP database and there's nothing to do, twdeployer returns errorlevel1. For this reason I now have to disable error catching for this step in our PowerShell script.Output of the same steps in a test batch file:Is there a way to not get errorlevel 1 when everything is just OK and nothing needs to be updated in the database?
Hi all,I want to create a deployment package and write it to the azure file storage. I have done this multiple times. However, now the procedure raises an error:Access to the path 'D:\Thinkwise\Applications\RIE_MANAGER\rie_tst_support_14032025\Deploy\Install' is denied.I'm not sure why this happened. Can it be caused by the platform upgrade (2025.1)? This is the first time creating a deployment package since the upgrade.Kind regards,Rick
I am trying to get the IAM language description updated, but I cannot figure out how. Some descriptions are not user friendly yet, so I have corrected them in the SF. SF Application languageI have synced one of our applications with the product IAM, assuming that this would control the languages available there, but when opening the menu there, I see the old result still. ex: bs-BA IAM languagesThe situation is based on 2025.1.
I'm having quite some disconnects with latest Indicium (2025.1.10) did anything change? I'm able to generate, validate, generate source code.. and with execute it sometimes already happens with the checks and most frequent with the indexes. ---> Microsoft.Data.SqlClient.SqlException (0x80131904): A transport-level error has occurred when sending the request to the server. (provider: TCP Provider, error: 35 - An internal exception was caught) ---> System.IO.IOException: Unable to write data to the transport connection: Connection reset by peer. ---> System.Net.Sockets.SocketException (104): Connection reset by peer Update:I just validated, by re-deploying another environment still on 2024.3 and this one doesn't have the disconnects. while it runs on the same specs (SQL version 2022 CU16). Treatment of disconnects:And can the platform handle these better? Now it's stuck.. you have to manually cancel the job.. it should detect this and retry or stop..
When using a lookup the header starts with only a title, when you click a row it adds a subheader which directly changes the height of the header, which in turn changes the position of the grid, making you miss double clicks. I’ve added a gif for reference.My idea is to give the header a fixed height, regardless of the existance of a subheader.😁
In most cases I want the roles to be setup manually for objects that were generated by a dynamic model. And in other cases where I do generate the roles, it sometimes also happens that a dynamic generated object is also manually assigned to a role. The problem is that when using a staged strategy for the dynamic model, it runs in an error when something does not exist anymore that was assigned to a role. To work around this, I currently have to write code in the dynamic model that deletes roles for everything that does not exists anymore. So I would like an option for the dynamic model with a staged strategy to automatically remove roles for something that does not exist anymore in the staged tables. Basically a cascaded delete.
I get a lot of these messages.. is this an issue at my side or is the store offline? Process action "oauth_server_login_connector_thinkstore_listing" in process flow "system_flow_thinkstore_refresh" in application 1050 returned the following message: "Connection refused (store.thinkwisesoftware.com:443)
Hello everyone,I am making a double task which I cannot resolve using variants, as I need to have both the task and the variant on the same table. So I made a copy of the task. The tasks are also connected to their respective process flows to simulate a 'go back’ action to a overlaying table.But both to a different variant of that table. Where one goes to a variant with a prefilter on a few statuses, the other goes to the other variant with the other statuses. Just to be sure I rebuilt the application via the default creation method, but now every time I try to do a refresh model action, I get the following error:I cannot figure out why this pops up, as the tasks seem to be configured properly, in the table task section as well as in the set up of the task. And the tasks are used to start the process flows, so the application can go back to the proper record and table variant of the prior table. What am I doing wrong? And this is how the task is configured, both are configured the same
i use a screen type with filter and grid, grid is filtered with 3 fields( production_date, business unit and product), when i select a date the records are shown, then i select a business unit which differs from the first record the records selection is changed but the filter business unit shows the value of the previous record (first or selected)I know we use filter more and it works like it should but in this case we get a stupid presentation of the filter. Can someone help me with a suggestion to fix this or is it a bug?? I have made a short clip of it if interested...
SQL Server Management Studio has been the backbone for writing queries and managing SQL Server databases for a long time now. I’ve been using SSMS for well over a decade.A new kid on the block - Azure Data Studio - is gaining popularity. This IDE has been around for a couple of years now and is a close relative to Visual Studio Code. And with the possibility of plugging in extensions such as GitHub Copilot, I’ve recently completely switched to Azure Data Studio.In this blog, I’ll highlight some of the features of Azure Data Studio and suggest some key binding changes which I did make the transition from SSMS to Azure Data Studio easier. Familiarize yourself with F1Not unlike Visual Studio Code, virtually all commands, actions and settings can be done in Azure Data Studio via the F1 menu. If you want to do something and you don’t see a button - always press F1.The F1 menu of Azure Data Studio Tab display sizeThis may be a personal preference - I always ensure tabs are back to their orig
Hi all,I have an issue getting the English Gui translations Base model to take effect in my model. What I did:Models → models Overview → branches → Base Modelsselected GUI_TRANSL_ENGLinked the model Generated DefinitionMy expectation was that the objects would have been translated, but this was not the case.
In 2025.1.10 the Grid has received a much-needed improvement regarding the highlighting of the active row. However this is not implemented yet for the Cardlist. When can we expect this?Because currently it looks kinda funny, when some screens have received the new highlighting while other have not.
Hi I'm not sure how this is called but a multiple same table tile is adding whenever a related page is open, instead of referring to a single small tile only. How to prevent multiple tiles open. Main Menu Tile screen Also, where to find the upper small tiles? under user interface → Menus, I can only see the main tiles Please advice Thank you
Good Day, I have a process flow (below) that does not display the variables display name on the Show message, write file and email connector.Process Flow I have a simple update task that update a certain field e.g. task_update_referenceTable Reference - is where I update the reference name, this table there is a company_id, this company id has a look up on Table Company, to display the column nameIn the task it's working fine, I can see the display name of the company id. My update task is also working. Task The process flow is working, except that the company display name in the Show message, write file and email connector, is not working. when I call the company_id it didn't show the display name, This is my process process variable is there a place I can configure to get the display name? Please advice or share any suggestions Thank you in advance!
Hi all,I want to create a task that will open the build in import functionality or (if possible) view the import function on the ribbon next to the CRUD buttons. I came across this post from 5 years ago. This was not possible back then. I am wondering if it is possible in the 2025.1 version.Kind regards,Rick
Hi, We face issues after the upgrade to TW 2025.1 with some screen types.In the past we imported a base model for screen types (> 5 years ago).But some of these screentypes are now corrupt and giving issues in the validations. We are not using those screentype any more, but as it is imported from base model, we can’t delete the screentype from the SF. And there is also no option to edit them.Is there a workaround to get those deleted?Thanks in advance
Hi We recently update the universal gui version to version 2024.3.15we notice that badge count is changing inconsistently. I'm attaching a video for you to fully understand, hope it can accept video attachment in pdf.Please advice. Thank you
I’m uploading an Excel spreadsheet using the import option into a view with a handler.The first test we noticed that only the first 50 records where uploaded, while there was no error.I copied the next 100 records to another tab, made a mistake in the mapping and got only 50 errors back.Does someone know how this is possible, and if there is a setting somewhere to solve this? We are kind of in a hurry as we have to upload 600 records today.
Hi,I created a report in DevExpress, and in the previewer, the columns appear exactly as I want, including the ones set to bold. However, when I use the preview component in Universal, those columns are no longer bold but appear in regular font.I use DevExpress Report Designer_1.70 and Universal GUI 2024.3.13.0.0. I checked in the Windows GUI, and the bold font is working fine, so it is just a Universal issue.Does anyone know how to fix this issue? See below the screenshots.Universal PreviewDevExpress Preview
Can the indicium container be equipped with ca-certificates which would allow us to register our self generated CA root certificate for encryption? Or any bright ideas how to achieve that without creating a custom container?
Hi,I was wandering if there is a way to hide a menu item based on some logic (like in a context procedure where you can hide task buttons)? This could for instance be as simple as when there is no data available. We are using Universal 2024.1.13.0
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.