Solved

How do I by default zoom out resource scheduler when opening for the first time (in Web GUI)


Hi everyone, I was looking for a way for web GUI resource scheduler to zoom out the times scale showing 8 months instead of 7 by default. I checked the documentation and the full model module in SF and I found the zoom factor under the web and windows setting in the extender, but they work differently from each other. In web its designed to be Boolean implying we are only enabling the feature and, in the windows GUI we are giving instruction what level of zoom are we requiring. Is there any other way of zooming out the time scale for the web GUI?

My current Time Scale 

 

I don’t find any difference after i enabled this option

 

icon

Best answer by Roel 25 August 2022, 13:06

View original

4 replies

Hello updates on my own discoveries with extender in full model:

  • We cannot zoom out in the set dynamic dates that we configured,unless its within the set maximum and minimum dates.

 

Userlevel 7
Badge +19

Hi Jefferson,

Seeing the challenges you are coping with, I have the feeling this might not work in the Web GUI as you would expect. Did you manage to solve it or still open?

Hi Mark,

This is still open, It would be nice if we can manipulate the position of the current date in this time table without sacrificing the date navigation since manipulating the maximum/minumum dates will disable the calendar and the left and right navigation because dates are already set as seen from my previous comment.

Userlevel 3
Badge +1

Hello Jefferson,

 

This issue is fixed from SF versions 2021.3 and above. From then on the control type is no longer a boolean but an integer. So the only way to fix this is to upgrade to a newer SF version. If you do so I would recommend to upgrade to the latest SF version, which has the newest features and will give you the least problems.

 

Downside of this solution is that the configured extender settings are stored in an xml format and are not updated with the upgrade. This means the old settings (with the boolean) will be kept in tact. You have to add a new scheduler extender and copy all the settings from the old one to the new one. In the new extender settings you will then be able to set the right integer for the web zoom factor you desire.

 

Hope this helps.

 

Kind Regards,

Roel

Reply