Solved

SVG icons in domain not inverting their color.

  • 9 November 2021
  • 3 replies
  • 32 views

A pretty nice feature of .svg images in the universal GUI is that they automatically adjust their color for readability.
 

Top original image
Bottom image while attached to a task



I was wondering why the color adjustment does not seem to happen when I use the image as a domain element icon (maybe its just grids in general).
 

Image used as a domain element icon
Domain element icon settings

Is there any way to achieve the svg color readability adjustment in a grid like this? 

icon

Best answer by Mark Jongeling 10 November 2021, 13:45

View original

3 replies

Userlevel 6
Badge +18

Hi Anne,

Try opening the SVG file inside an editor like Notepad. The SVG most likely is containing a style="" element which also names a color. Remove the entire style="" from the file and then save the file. This will make sure the SVG can be recolored by the GUI.

Remove this line - If your icon has overlay(s) also remove it further down.
Fixed

 

Hi mark,

That does not seem to be the problem because the icon does work (inverts color) when attached to a task. And it has no style attribute in its code. 

The problem is that when this(or any svg) icon is attached to a domain element as an icon it does not invert color's. 

Userlevel 6
Badge +18

Hi Anne,

I contacted the Universal GUI team, they know about it and it's on their backlog to be implemented. For know the color will not change for domain element icons.

Reply