Setting up "forgot password" error in logs

Badge +2

I tried to set up the “forgot password” function in IAM. So I filled in Global settings the email service and the IAM user has the function “change password” on. But I get some strange errors in the logs of Indicium after I use the forgot password function. 



Best answer by rbiram 29 August 2023, 13:20

View original

16 replies

Userlevel 4
Badge +2

It looks like Indicium can not access the `Server address` that is configured in Global Settings.

Did you restart Indicium after configuring the SMTP Email provider?

Badge +2

Yes I restarted the app-service several times but it doesn't change. If I use the same SMTP data in a process flow it works.

Badge +2

I still need help with this!

Userlevel 4
Badge +2

We would like to have some additional information.

You are mentioning “App-service”, so are you running Indicium on Azure?

Are you using the latest Indicium version?

Are you using some kind of SMTP relay service like SendGrid or something else?

The “No such host is known” error indicates that the DNS server can not translate the `server address` to an ip address. Which sounds like a configuration error.


Badge +2

Yes we running Indicium on Azure and use the latest Indicium version.

We use MailJet. But I used the same settings in een SMTP-connector in a processflow and it works and when I use those settings in IAM, I get an error. 

Below our Global settings in IAM


Userlevel 4
Badge +2

Thank you for your reply.

If you execute the following query on your IAM database. Do you see the information you expect to see? Just a guess, but if you did copy the adres from somewhere it might contain weird (invisible) characters - can you try to manually type it in again?

select * from i_core_system_email

It is difficult for me to test as I don’t have a Mailjet account.

Badge +2

With that query I get the same information as showed in IAM. Not with strange characters, the address is something like this:

Thank you.

Userlevel 4
Badge +2

I don’t think you should add the `https://` when using SMTP.

According to the Mailjet documentation it should be correct?

Badge +2

Yes, I have indeed tried that.

Userlevel 4
Badge +2

Hi groos,

I updated my environment on Azure to test this situation. I didn't use a Mailjet account so my error about authentication is to be expected. I did use of course the Mailjet SMTP address, as documented in their documentation.

I used the following configuration in IAM (Global settings > Email providers):

SMTP configuration in IAM


With the above configuration I get an expected authentication error:

Expected authentication error from Mailjet

So, it looks like it is connecting successfully to Mailjet (and not getting the “No such host is known” error).

Is your Azure App Service by any change configured to use “VNet integration” with a custom DNS server? In my case, my Virtual network is configured to use the “Default (Azure-provided)” DNS server.

Virtual Network configuration


ps. Did you also update the “From address” in the Email templates detail tab (also found in Global settings)? If not, an error will occur - but it is different from the “No such host is known” error you are getting.

Userlevel 4
Badge +3

Hi Dick,

My colleague is on vacation, so I'll be checking this out.

Our app service is configured to use VNet integration, but not with a custom DNS. Same as you, ours is configured to use the Default server.

Also double checked if the ‘From address’ is filled in the templates, it is.

I've also checked in the Log Analytics Workspace to see if there's some kind of rule that's blocking something, but there's nothing there as well.

Like my colleague said, sending an email with the same settings in an SMPT connector from within the SF itself is no problem and works like a charm. Can't see why we're getting a ‘No such host..’ error.

Userlevel 4
Badge +3

This now works after changing the ‘From address’ to an updated address from our customer. Seems the address now gets recognized by the DNS server. 

Thanks for looking Dick.

Userlevel 4
Badge +3

Hi @Dick van den Brink ,

We're currently running into another problem concerning Mailjet. 

We're getting an error in the logs when trying to send an email with a systemflow: 

The server response was: 5.7.1 <’’>: Relay access denied

Sending an email via the IAM Password Reset functionality with the same Mailjet settings works fine.

We've checked nearly every setting in the SF and Mailjet, and we're sure the DNS server is set up correctly on the other side. Also looked in Azure if there's any outbound calls are getting blocked, but nothing there as well. 

Do you have an idea on what else to check?



Badge +2

Hello, we still need help on that issue above! ^^

Userlevel 4
Badge +2


It would help to provide more information because above it was mentioned it was working from Process flows and now it is not working from a System flow.

From an Indicium perspective, there is no real difference between a System flow and a (user) process flow - so did it suddenly stop working?

In 2023.2 it is possible to override the `Email` provider on the application level, this can be found in IAM in the Applications screen on the Email providers detail. is the data here also as expected?


Badge +2

Hello, we fixed the issue. It was caused by an error in the provider's credentials. Tnx