Indicium Universal - Error 500

  • 9 June 2020
  • 4 replies

Userlevel 5
Badge +20

How come I get a 500 error?

I want to install Indicium Universal, because I want to use the process flow scheduler functionality.

How is the configuration different from the installation of the 'old' Indicium?

How do I know that the correct version of .NET Core Windows Hosting Runtime is running?


Best answer by Vincent Doppenberg 12 June 2020, 11:24

View original

4 replies

Userlevel 6
Badge +4

Hello Harm,

The installation requirements and configuration of Indicium and Indicium Universal aren't different. What is written in our installation manual should work for both versions. I'll list the reasons for getting a 500 error upon startup below and also some tips to figure out what the problem is.

Reasons for 500 errors on startup:

  1. A syntax error in the JSON of the appsettings.json. This could be as simple as forgetting a comma or a closing bracket, but it could also be forgetting to escape a backslash in, for instance, the server name.
  2. The connection settings for the IAM database in the appsettings.json are invalid. The server or the database don't exist or the database pool user of Indicium does not have access to the database.
  3. The major version of Indicium is lower than the version of IAM.
  4. The version of IAM is lower than 2018.3.
  5. The files in Indicium’s folder are blocked due to security reasons (see file properties) because Indicium was downloaded through the TCP Web GUI and not extracted using 7-zip.
  6. Version 4.7.2 or higher of the .NET Framework is not installed.
  7. Version 2.2.7 of the .NET Core Windows Hosting Runtime is not installed.
  8. The URL Rewrite module for IIS is not installed.
  9. The Application Pool identity does not have sufficient access to Indicium's folder.

Tips for troubleshooting startup errors:

  • First always check Indicium's log files to see if you can find an explanation in there. Errors caused by points 1-4 will show up in these log files. If one of them shows up, validate the contents of your appsettings.json and the database pool user's access to the IAM database.
  • Check if you can run Indicium.exe from Indicium's folder with the same user as the Application Pool identity in IIS. If the log files didn’t have any useful information, the console will definitely show these errors as well. Furthermore, determining whether Indicium.exe will run or not will further narrow down the cause of the issue. If you get the “Application started.” message in the console, then points 5, 6, and to some extent point 7 (at the very least you'll have the .NET Core 2.2 runtime but perhaps not the hosting module) can be ruled out as well. If Indicium.exe does not start, have a look at points 5-7. If it does start, this means the problem is entirely related to IIS.
  • Check the modules in the IIS Manager to see if you have the AspNetCoreModuleV2 and RewriteModule installed. This will confirm or rule out points 7 and 8. The installation manual explains how to install these modules. If both are installed, check the Application Pool identity for point 9.

I hope this helps.

Userlevel 5
Badge +20


Thank you very much for the clear explanation.

Installing version 2.2.8 of the .NET Core Windows Hosting Runtime was required for it to work.

For inexperienced people like me, it is quite difficult to verify that the correct versions of .NET Framework and .NET Core Windows Hosting Runtime are installed. And which installation files to download. 32 or 64 bit, etc ..?

Perhaps you can add how to determine if the correct versions of .Net Framework and .Net Core are installed. And add the complete explanation for solving a 500 error to the documentation.




Best regards,




Userlevel 7

Hi Harm,

Thanks for the suggestion, we will add this to the documentation.

Userlevel 2
Badge +3

In addition, even though Microsoft are stating that .NET Core 2.2 is EOL, installing .NET Core 3.1 will not work for Indicium Universal at this time. (I have not tried .NET 5.0 yet)

Instead I also used version 2.2.8 which worked fine.