Question

Startup application on SF (not using iAM)

  • 8 September 2020
  • 3 replies
  • 47 views

Userlevel 4
Badge +7

Does anyone can help me out, starting my end user application ‘against’ the SF.

I’m testing the upgrade from the SF 2018 tot the 2020.2 version, but I’m really struggling starting up the end-user APP ‘against’ the SF.

In the 2018 version we have several INI files and in 1 of them 

metasource          = sf
server                   = nlveksa-sql-01
database              = saan_sf
runtimeconfiguration     = null
authentication      = mswindows
project                  = SERP
projectversion       = null

language                 = nl
executionmode     = developer

I read the blopost 

but this don’t give me a clue how how to accomplish this.

I read about the runtime configuration but I don’t see a solution to start the application ‘against’ the SF.

I tried a (according the old fashioned way) a new INI and a new shortcut (refering to this new INI) with the following settings.

metasource = sf    
rdbms = SQLSERVER
server = nlveksa-sql-01
project = serp
projectversion =null
database = saan_sf_test
language = EN
authentication = MSwindows
globalconfiguration = null
executionmode=developer

The application does start with the new 2020.2 GUI and the correct project version but gives me an error:

An error occured when trying to read property: tab_id.

   at Thinkwise.Shared.Extenders.TSFExtender.GetSingleRootPropertyByName(String propertyName)    at Thinkwise.Shared.Extenders.MapsExtender.CreateMaps()    at Thinkwise.Shared.Extenders.TSFExtendedModelReader.Apply(TSFList`1 extenders, ObjectModelFillHelper fillHelper)    at Thinkwise.Shared.ObjectModel.SPResultTable.get_gui_extender_property.ReadAll(SPResultTableReader reader, ObjectModelFillHelper fillHelper)    at Thinkwise.Shared.ObjectModel.GetGUIReader.Fill(SPResultTableReader sfReader, ObjectModelFillHelper fillHelper)    at Thinkwise.Shared.Async.ObjectModelFillScheduler.<>c__DisplayClass7_0.<createReadTask>b__0(SPResultTableReader resultTableReader)

So now I’m stuck in the middle… Can anyone help me out?

 

 


3 replies

Userlevel 7
Badge +14

Hi Edwin,

I'm not completely sure why it doesn't work for you. The .ini looks right to me. I have a suggestion, can you check the Runtime Configurations in the SF? The Runtime configurations need to be active for the user you are trying to log in with I believe.

 

Hopefully this does the trick!

Userlevel 4
Badge +7

I don’t see myself as a user. I see other users (Thats the name of the TAB). 
So I’m not able to check or uncheck… The system knows that I’m saan\esa. I’ve logged in with the windows credentials

 

Userlevel 4
Badge +7

I already found it. In the error messaging I see code regarding to the maps component.

This is a component we’re not using yet. So I deleted the extender in this project version and the application does start now.

I was a bit a guess, but in this case a good gues.

Reply