Solved

Error Maps component

  • 19 August 2019
  • 7 replies
  • 121 views

  • Thinkwise Local Partner Brasil
  • 4 replies
For a Demo App, I am trying to integrate the Maps component. However I am getting an error, any ideas where to look for solutions? It's a 404 error. The documentation for me is not sufficient to know where to look for possible answer to this error.

icon

Best answer by Jop ter Horst 20 August 2019, 16:03

Hi Freddy,

Did you sync the model to the Intelligent Application Manager?
I tried a number of things, and it works now.

I did delete a couple of map layers, it could be that they were the problem, but it also could be that a synchronisation to the IAM was necessary.

You could try adding the layer and corresponding library configurations one by one, you can test the application after each layer and see where the problem is.

Further, for testing while developing it is more practical to open the application against the Software Factory database instead of the Intelligent Application Manager database, so you can simply refresh the model and see the changes you've made. Did you know this already?
View original

7 replies

Userlevel 5
Badge +5
Hi Freddy,

Based on this screenshot I can't exactly see what the problem is.

I noticed you're using a remote environment that is hosted at Thinkwise. I can put out a request to our Infrastructure department so I can log into your environment and investigate the problem.

Are you okay with that?
Definitely, please do so.
Userlevel 5
Badge +5
Hi Freddy,

Did you sync the model to the Intelligent Application Manager?
I tried a number of things, and it works now.

I did delete a couple of map layers, it could be that they were the problem, but it also could be that a synchronisation to the IAM was necessary.

You could try adding the layer and corresponding library configurations one by one, you can test the application after each layer and see where the problem is.

Further, for testing while developing it is more practical to open the application against the Software Factory database instead of the Intelligent Application Manager database, so you can simply refresh the model and see the changes you've made. Did you know this already?
I know about it, but I don't know how to achieve that. I think it requires a custom ini file right? Any documentation on this subject?
Hi Freddy,

Did you sync the model to the Intelligent Application Manager?
I tried a number of things, and it works now.

I did delete a couple of map layers, it could be that they were the problem, but it also could be that a synchronisation to the IAM was necessary.

You could try adding the layer and corresponding library configurations one by one, you can test the application after each layer and see where the problem is.

Further, for testing while developing it is more practical to open the application against the Software Factory database instead of the Intelligent Application Manager database, so you can simply refresh the model and see the changes you've made. Did you know this already?


I guess it must be one of the layers, although I checked all URL manually.
Userlevel 5
Badge +5
I've added a custom .ini for you in the TSFShortcuts folder on the desktop in your demo environment.
You can drag this file onto the Software Factory shortcut to open the application.

Basically, the ini is a text file where you declare parameters. What's important when opening against the Software Factory is that you enter the SF database, instead of the IAM database. Also, since the SF end product doesn't have any user preferences, you have to declare the language you want to use, the project, project version (if null it will select the newest one) and execution mode. If you have developer as execution mode you have access to the 'Refresh model' button.



You can read more about .ini files and the ini parameters here.
https://office.thinkwisesoftware.com/docs/docs/sf/configuration_file.html#docsNav

If you have any more questions, don't hesitate to ask them!
Userlevel 5
Badge +5

Hi Freddy,

Did you sync the model to the Intelligent Application Manager?
I tried a number of things, and it works now.

I did delete a couple of map layers, it could be that they were the problem, but it also could be that a synchronisation to the IAM was necessary.

You could try adding the layer and corresponding library configurations one by one, you can test the application after each layer and see where the problem is.

Further, for testing while developing it is more practical to open the application against the Software Factory database instead of the Intelligent Application Manager database, so you can simply refresh the model and see the changes you've made. Did you know this already?
I guess it must be one of the layers, although I checked all URL manually.


There is a lot of data to enter, so a mistake is easily made unfortunately.
The model extenders are extra functionality on top of the model of the application, so hopefully it will be integrated in the model and easier to configure in the future.

Reply