Sorted combo not working (still alphabetical)

  • 24 August 2019
  • 2 replies

Userlevel 4
Badge +13
We just upgraded to version 2019.1 and I immediately tested the new sorted combo in one of our tables. However it doesn't work and despite setting the lookup as 'sorted' the drop-down still appears alphabetical.

I followed these steps:

First I set a default sort on the lookup table:

This table holds sizes with an ID and a description where the sizes are sorted by a sorting column called "weergave_volgorde", for example to show sizes in the order of S, M and L (with corresponding order values of 1, 2 and 3). This sorting column is part of the default sort. I also tried sorting on this column alone with the same result.

Then I set the following lookup:

Where vw_maat is the lookup table in the previous image. As you can see I set the look-up control to a sorted combo.

However the end result still appears alphabetical:

EES should be at the top of the list because this is how it sorts in the lookup table by default whereas 9EL should be at the bottom. Of course there are more sizes but it should be clear that the combo does not appear as expected.

Am I missing something here or is this perhaps a known issue?

Best answer by Roland 26 August 2019, 01:44

View original

2 replies

Userlevel 4
Badge +13
I figured it out. There is also a lookup setting in the subject settings tab. I changed the lookup to sorted there and now it's working as aspected.

It's really nice to have this option now! I just have to remember to set it as a sorted lookup in both the subject itself and in the actual lookup.
Userlevel 6
Badge +11
A smart way to earn a 'best answer' 😉, haha. Nice that you solved it yourself!