Solved

Software Factory error during Executing Source Code

  • 22 February 2023
  • 4 replies
  • 117 views

Userlevel 2
Badge +1

Recently we've upgraded to SF2023.1 (with all hotfixes including 202300116 - Subrouting option copying from base models’ applied). Everything went well and we done some model generations with this version of the SF.

However, after merging a branch recently, we’re facing an error during the execution of the functions. The creation of the function ‘tsf_original_login’ fails because the script contains duplicate lines for ‘returns varchar(128)’ and ‘with schemabinding
 


How to solve this? Any help would be appreciated.

icon

Best answer by Dick van den Brink 22 February 2023, 12:51

View original

This topic has been closed for comments

4 replies

Userlevel 2
Badge +1

@Dick van den Brink Thanks for your quick reply. I will test the proposed solution by @Erwin Ekkel and let you know if it solved the problem.

Userlevel 2
Badge +1

The proposed solution worked for me. Thanks again @Dick van den Brink 

Userlevel 4
Badge +2

Here someone had the same problem.

The comment of @Erwin Ekkel might help you, but probably we also need to look into it, so other people don't run into this problem.

Userlevel 2
Badge +4

I would like to point out that I also ran into this problem since after upgrading SF to 2023.1. However not in every model (project).