Solved

Set number of copies in process flow report

  • 23 April 2024
  • 5 replies
  • 55 views

Userlevel 4
Badge +11

How do I set the number of copies in a process flow which calls a report. I added the gui_rpt_number_of_copies parameter. I give it a value in the default of the task which triggers the process flow. I added a parameter gui_rpt_number_of_copies in the process flow. The parameter gets its value, but in the report step the parameter is set to 1.

 

 

icon

Best answer by Edwin Saan 17 June 2024, 15:49

View original

5 replies

Userlevel 4
Badge +3

Hey Edwin,

Maybe this is a so-called open door question, but did you pass along the value of the parameter from the task in the process flow to the process action that calls the report? If the task doesn't provide the gui_rpt_number_of_copies as an output parameter it would be hard for the report action to know what the value has to be.

I suspect that the parameter being set to 1 is due to a default value, hence why it'll always be 1.

Does this help at all?

Userlevel 4
Badge +11

Renee,

 

Yes, I did but I will double check if I’ve not made a typo somewhere.

From your answer I understand that when I define the parameter in the process flow and I give it a value, the number of copies would be aumatically passed to the report action. (Because there are no input parameters defined in the process flow action)

This is exaclty what I do but somehow the process flow overwrites the parameter value I send from the task.

 

Userlevel 4
Badge +3

Hey @Edwin Saan ,

Pardon me for not replying sooner, this topic went somewhat under the radar somehow.

Did you manage to get this working by now? If not, can we be of any further assistance regarding this topic? If you need any additional assistance it would most definitely be beneficial for us to have some screenshots of your task, process flow, etc. to have a look at 😊 This provides us with more insights into how everything is set-up and what might have been configured incorrectly.

Kind regards,

Renée

Userlevel 7
Badge +23

Hi Edwin,

If the Report parameter uses Report property Number of copies but does not print the given number of copies, we need to look into it. If the problem is not solved, could you create a ticket in TCP and attach a model.dat of the branch in which this problem occurs?

Thanks!

Userlevel 4
Badge +11

All, I solved it on another way. I’ve put the print process in a process flow which now runs iterations for the number of copies. I don’t have time trying to reproduce the issue. 

Reply