Solved

Indicium requires RequireHttpsMetadata=false setting but how do I set this?

  • 5 December 2022
  • 2 replies
  • 501 views

Userlevel 6
Badge +16

I can no longer navigate to my local indicium instance. It's giving me a 500 error and the log shows this error: 

2022-12-05T13:46:28.4343183+01:00 8000000b-0009-ff00-b63f-84710c7967bb [ERR] An unhandled exception occurred while processing the request. (ffba027a)
System.InvalidOperationException: The MetadataAddress or Authority must use HTTPS unless disabled for development by setting RequireHttpsMetadata=false.

Where do I set this setting? I can't find any documentation on this. Do I set it in the appsettings or web config? And in what section does this need to be added?

icon

Best answer by Vincent Doppenberg 5 December 2022, 14:03

View original

2 replies

Userlevel 6
Badge +16

Vincent, I once added a open id provider line to test something for a customer. I had no clue this had an impact on the indicium instance. Removing this line from the sf solved the problem. 

Userlevel 6
Badge +4

Hello Erwin,

We don't actually have a ‘RequireHttpsMetadata’ setting, this error message comes from a component that we use.

To resolve this problem, follow the following steps:

  • If you have OpenID providers configured in IAM, ensure that their Metadata endpoints use the https:// scheme or remove them.
  • If you have OpenID clients configured in IAM and you have the BearerTokenAuthority setting configured in your appsettings, make sure that it uses the https:// scheme or remove it.

Hope this helps.

Reply