HTTP connector giving -1 output for user creation

  • 21 November 2022
  • 4 replies

Userlevel 2
Badge +5


While trying to create user in IAM, the user is getting created when using Insomnia (after disabling SSL). The GUI version is : 2022.2.16.0

The complete process worked form SF when the URL did not have SSL certificate.

However for the URL with SSL certificate, the HTTP connector returned -1 .

Can you please guide, how can I get it correct?

it worked for insomnia
HTTP connector input



Best answer by Rucha Naik 22 November 2022, 09:46

View original

This topic has been closed for comments

4 replies

Userlevel 7
Badge +5

The cookie and response code indicate that the server could be reached and authentication succeeded.

Can you verify the user has administrative rights to be able to even access the user entity in IAM?

Userlevel 2
Badge +5

Hi Anne,

The user has admin rights to create users in IAM. However I tried with another user, which was created as super admin. The process worked with it. How can I check if such rights are present or not? 

Userlevel 7
Badge +5

Hi Rucha,

Within IAM, the user can obtain the correct administrative roles through certain settings:

When you start the environment as this user, you should also see that the user has access to IAM and can perform the necessary actions though the UI.

Userlevel 2
Badge +5

Thanks a lot Anne! This helps a lot.