Solved

How to set up the Process flow monitor in universal

  • 25 October 2023
  • 7 replies
  • 233 views

Userlevel 4
Badge +1

Hi,

 

With the recent release, I was curious to use the process flow monitor in Universal.

However, after trying via different routes (IAM, indicium in developer mode) the monitor stays empty. 

 

The documentation about this new feature is quite brief. Could anyone explain what steps must be followed, other than having Developer mode in IAM?

 

Kind regards,

Mark

icon

Best answer by Vincent Doppenberg 25 October 2023, 11:02

View original

This topic has been closed for comments

7 replies

Userlevel 7
Badge +23

Hi Mark,

The monitor registeres process flows from the moment you open the monitor. To my knowledge, the page has to remain opened during working in your application. Any process flow you initiated will be recorded and shown on the page.

Userlevel 6
Badge +4

Hello Mark,

It has come to our attention that one of the prerequisites for the process flow monitor is missing in our documentation. In order for the process flow monitor to work, you will need to turn on the WebSocket Protocol feature of IIS.

We will make sure to include this in our documentation very soon.

I hope this helps.

Userlevel 6
Badge +16

We recently discovered websockets needs to be active. Can you check if this is the case? 

 

 

Userlevel 4
Badge +1

I have turned on the Websockets, now works like a charm!

 

Userlevel 6
Badge +10

@Vincent Doppenberg Could you also add this information to the Release notes of Indicium 2023.3.10? I can't find the information in the Docs yet and had to stumble on this topic to find out this important pre-requisite.

Userlevel 6
Badge +10

@Vincent Doppenberg Another thing we encounter on our environment is the following error, this seems to be due to the fact that we have setup the Content Security Policy for the Universal GUI as per documentation: https://docs.thinkwisesoftware.com/docs/deployment/iis#content-security-policy-header.

And since Indicium is a child application, the more restrictive script-src 'self'; on the Universal GUI CSP is overruling the Indicium script-src 'self' ‘nonce-...’ setting.

What would you recommend us to configure in the Universal GUI CSP? Preferably we stay away from the need to use the ‘unsafe-inline’.

 

Userlevel 6
Badge +10

@Vincent Doppenberg Another thing we encounter on our environment is the following error, this seems to be due to the fact that we have setup the Content Security Policy for the Universal GUI as per documentation: https://docs.thinkwisesoftware.com/docs/deployment/iis#content-security-policy-header.

And since Indicium is a child application, the more restrictive script-src 'self'; on the Universal GUI CSP is overruling the Indicium script-src 'self' ‘nonce-...’ setting.

What would you recommend us to configure in the Universal GUI CSP? Preferably we stay away from the need to use the ‘unsafe-inline’.

 

The documented solution to Remove the CSP Security Header in the Indicium web.config actually does the trick:

If the Universal GUI is in the root of the web server and Indicium is a child application, Indicium inherits the custom headers listed in the web.config. This will cause duplicate headers in the Indicium application which might cause issues. You can remove them by adding <remove name="X-Frame-Options" />and the other custom headers in the Indicium web.config file.