Solved

Getting error message while using Universal GUI (2021.3.13.0)

  • 14 March 2023
  • 3 replies
  • 90 views

Userlevel 5
Badge +20


There is nothing wrong with the SELECT statement, it runs fine in the Windows GUI. I have checked all expression fields.

The Error Log doesn't help to solve the problem.

Please help!      (Indicium: version 2023.1.13.3  Universal: version 2023.1.13.0.0)

2023-03-14T14:44:36.5121510+01:00  [INF] License refresh scheduled for 2023-03-16 12:54:28. (09ff7cde)
2023-03-14T14:49:41.9984947+01:00 8000008e-0000-fd00-b63f-84710c7967bb [ERR] An unhandled exception occurred while processing the request. (ffba027a)
Indicium.Shared.TSF.FatalDbException (0x80004005): The following query failed with an exception: 'SELECT t1.[epos_id], (FORMAT(ISNULL(t1.epos_id, 0), '000000')
) AS [epos_dx_id], t1.[epos_ett_id], RTRIM(t1.[epos_row_guid]) AS [epos_row_guid], t1.[epos_agent_client_number], t1.[epos_trade_tag], t1.[epos_from_location_code], t1.[epos_to_location_code], RTRIM(t1.[epos_means_of_transport]) AS [epos_means_of_transport], t1.[epos_container_quantity], t1.[epos_container_size], RTRIM(t1.[epos_container_type_id]) AS [epos_container_type_id], t1.[epos_remarks], t1.[epos_tariff_fcy], t1.[epos_currency_code_fcy], t1.[epos_total_amount_fcy], t1.[epos_status], t1.[epos_insert_date_time_utc_to_local], t1.[epos_insert_user_name], t1.[epos_update_date_time_utc_to_local], t1.[epos_update_user_name], (FORMAT(ISNULL(t1.epos_id, 0), '00000') + ' - ' + ISNULL((SELECT TRIM(company_name) FROM client WHERE client_number = t1.epos_agent_client_number), '????') + ' | ' + t1.epos_from_location_code + ' > ' + t1.epos_to_location_code + ' | ' + CAST(t1.epos_container_quantity AS varchar(10)) + ' x ' + t1.epos_container_size + 'ft'
) AS [epos_dx_main_screen]
FROM [empty_repositioning] t1
ORDER BY t1.[epos_id] ASC
OFFSET 0 ROWS FETCH NEXT 100 ROWS ONLY '
---> Microsoft.Data.SqlClient.SqlException (0x80131904): Invalid object name 'empty_repositioning'.
at Microsoft.Data.SqlClient.SqlCommand.<>c.<ExecuteDbDataReaderAsync>b__208_0(Task`1 result)
at System.Threading.Tasks.ContinuationResultTaskFromResultTask`2.InnerInvoke()
at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)

 

icon

Best answer by Harm Horstman 15 March 2023, 07:56

View original

This topic has been closed for comments

3 replies

Userlevel 7
Badge +23

Hi Harm,

The database the Universal GUI is interacting with (via Indicium of course) does not know the empty_repositioning table/view I think. Could it be the application is using a different database you were expecting?

Userlevel 5
Badge +20

Mark, 

The table exists int de database, we are running via SF and there is another new table in the same branch working without problems.

Userlevel 5
Badge +20

Mark,

Finally found what is the problem. Thanks for you suggestion, it helped me.

I had to adjust the active Runtime Configuration for the user.
 

Maybe it is an idea to give information of the current Run Time configuration in the About popup or in Model Insight?