Solved

Chrome & Edge block document preview in Universal GUI


Userlevel 4
Badge +5

 Running GUI version 2023.1.17.1.0, when trying to view a PDF file in the preview component I get the error ‘This page has been blocked by Chrome / Microsoft Edge’:


It does however seem to work using Firefox, which means there is something going wrong with Chromium browsers. Might it have something to do with the following?
 

BREAKING: Chromium browsers no longer support http://

Some of Indicium's authentication features, such as Single Sign On (SSO) and Single Logout (SLO), require Indicium's authentication cookie to have the samesite=none attribute. Chrome has recently made a change that causes cookies with this attribute to only work when the cookie is secure, meaning that the cookie was requested and received over a secure channel (i.e. https://). Consequently, you can no longer log in over http:// when using Chromium-based browsers such as Chrome and Edge, and this behavior will likely extend to more browsers in the future.

We already require usage of https:// in production environments, but if you must do testing over http:// then a different, non-Chromium browser needs to be used, such as Firefox. We will look into minimizing the inconvenience of this in our next release, by looking into not using the samesite=none attribute when it is not required. However, since we can no longer guarantee that all of Indicium's features will work over http://, we recommend using https:// for both development and testing environments.

 

On our Azure environment, HTTPS Only is turned On.

 

icon

Best answer by Erik Brink 6 June 2023, 11:28

View original

This topic has been closed for comments

5 replies

Userlevel 6
Badge +4

Hello Marius,

If you open the browser's developer tools with F12, you will probably find the reason in the either the Console or the Network tab. If you could share a screenshot of that, that would be helpful.

Userlevel 4
Badge +5

Hello Marius,

If you open the browser's developer tools with F12, you will probably find the reason in the either the Console or the Network tab. If you could share a screenshot of that, that would be helpful.

Console
Blocked requests in network console
When opening the Request URLs in a separate window, it works fine

 

Userlevel 4
Badge +5

Hello Marius,

If you open the browser's developer tools with F12, you will probably find the reason in the either the Console or the Network tab. If you could share a screenshot of that, that would be helpful.

Did you manage to find anything? Or is more information needed? 😀

Userlevel 5
Badge +5

For security reasons it is not allowed by default to link to web-sites which are not on the same origin, using an URL-type column. 

Since the URL delivers files, I would suggest you to use a file-type column, where the file-storage of the column in the Software Factory refers to the source url of the files. Is that an option here?

This way Indicium will prepare the files to this in a html-type frame to show the file-type in the best way in the browser. And because the files come from Indicium there are no CORS issues, like you are facing now.

Userlevel 4
Badge +5

For security reasons it is not allowed by default to link to web-sites which are not on the same origin, using an URL-type column. 

Since the URL delivers files, I would suggest you to use a file-type column, where the file-storage of the column in the Software Factory refers to the source url of the files. Is that an option here?

This way Indicium will prepare the files to this in a html-type frame to show the file-type in the best way in the browser. And because the files come from Indicium there are no CORS issues, like you are facing now.

Changing the column to a file-type column fixed this, thanks!