Solved

Background color of prefilter icons

  • 17 October 2020
  • 12 replies
  • 186 views

Userlevel 2
Badge +5

The theme for our application was developed a long time ago (2014 with TSF G8).

Because we are now using the screentype component “Prefilterbar” more often, we need to improve how this looks. When we designed this, apparently the background color was set to gradient (white to gray) but now it is not always clear when a prefilter is active or inactive. This is especially a problem in the web GUI. In the Windows GUI it does look how we would like to have it.

This is how it looks in the web GUI (no clear contrast between active and inactive):

 

 

This is how it looks in the Windows GUI (clear contrast between active and inactive):

 

The same theme is used for both platforms. What do I have to change to improve the look and feel for the inactive prefilters the web GUI?

icon

Best answer by Mark Jongeling 17 November 2020, 13:56

Hi Johan,

Seeing the difference between Windows and Web GUI, I do think it requires more in depth look of one of our Service & Care team members. Personally I think the icons are correct so it might be a bug, but it could also be a theme setting. Could you report a Question for this in TCP

I hope they can help you out and achieve the right look of your application.

Kind regards,
Mark Jongeling

View original

This topic has been closed for comments

12 replies

Userlevel 6
Badge +17

Hi Johan,

Could you tell me which Windows and Web GUI version you are using?

Edit: Maybe this topic can help: 

Kind regards,
Mark Jongeling

Userlevel 2
Badge +5

Hi Mark,

Based on the suggested article, I changed the settings for all columns with “Gradiant direction" to “None” in “Themes | Navigation | Ribbon”.
 


It effects the look of the Ribbon (as expected) but unfortunately not the buttons for the prefilter in the web GUI.
 

 


We are currently using version 2019.2.17 for both the Windows as the web GUI.

Any suggestions?

Userlevel 6
Badge +17

In the most recent version of the Web GUI this is no longer the case so I think it has been changed in a more recent version of the GUI. Could you download a more recent version of the Web GUI and see if that solves it? 

You did mention the theme has been created in the G8 but could you tell me which version of the SF/IAM you are currently using?

Userlevel 2
Badge +5

Hi Mark,

I already downloaded a more recent version of the web GUI (2020.2.19) because of the implementation of mass updates.

We are currently using SF 2018.3. I know we need to upgrade this as well, but I foresee a lot of work (and possible problems). I’ll need some help with that as well, but that's a different issue. :slight_smile:

Userlevel 6
Badge +17

Hey Johan,

So the problem still exists even when you are using the 2020.2.19 Web GUI?

And our Service & Care team can help you further with the upgrade to a newer platform. You can submit a ticket in TCP for support.

Kind regards,
Mark Jongeling

Userlevel 2
Badge +5

Hi Mark,

No, sorry! I see that I was not very clear in my previous response. I downloaded web GUI 2020.2.19 but did not test with it yet. I am not able to install a new version now because we have to release a new version of our application this week. But I’ll get back to you on this next week.

I’ll add a ticket in TCP for support on upgrading our TSF.

Userlevel 6
Badge +17

Hi Mark,

No, sorry! I see that I was not very clear in my previous response. I downloaded web GUI 2020.2.19 but did not test with it yet. I am not able to install a new version now because we have to release a new version of our application this week. But I’ll get back to you on this next week.

I’ll add a ticket in TCP for support on upgrading our TSF.

Hi Johan, 

Did the newer GUI help? I'm keen to know :wink:

Kind regards,
Mark Jongeling

Userlevel 2
Badge +5

Hi Mark,

Unfortunately it still looks the same with web GUI 2020.2.20.

Any suggestions?

Thnx!

Kind regards,
Johan

Userlevel 6
Badge +17

Hi Johan,

When I compare it to TCP, I start to wonder if it may be the icons themselves:

TCP → Issue prefilters

It could be a combination of the background color given by the Theme and the icon background. Could you attach one of the icons to your next reply? 

Kind regards,
Mark Jongeling

Userlevel 2
Badge +5

Hi Mark,

That does not explain why it works fine in the Windows GUI.

But hereby the icons:

Kind regards,
Johan

Userlevel 6
Badge +17

Hi Johan,

Seeing the difference between Windows and Web GUI, I do think it requires more in depth look of one of our Service & Care team members. Personally I think the icons are correct so it might be a bug, but it could also be a theme setting. Could you report a Question for this in TCP

I hope they can help you out and achieve the right look of your application.

Kind regards,
Mark Jongeling

Userlevel 2
Badge +5

Hi Mark,

That is what I already said yesterday. I want to report things in one place and not once in the Community and afterwards also in TCP. That does not work for me. I was told that I did not have to do things twice when Thinkwise switched to this Community Portal!

Like I said: Create a connection between this portal and the old TCP if you still want to use the old TCP as well.

Kind regards,
Johan