Solved

Two (or more) reports in a process flow on multiple records

  • 16 July 2019
  • 8 replies
  • 88 views

Userlevel 1
Badge +2
The situation is the following:
I have two reports. When I run both reports seperately on a collection of records, it will give me a report for each record. First a report for the first record, then a report for the second and so on.

What I would like to achive is:
I would like to make a process flow to execute both reports on a collection of records and then I would like to be presented with the first report for the first record, then the second report for the first record, then the first report for the second record followed by the second report for the second record, and so on.

I haven't been able to achieve this. It appears like I am not able to cary forward the collection of records to the second process action.

I hope my question is clear. Any help or hints would be appreciated.

Thanks.
icon

Best answer by Erik Brink 17 July 2019, 08:54

Hi Dennis,

I think the best way to accomplish this is to navigate to a row using processflows, execute the report and continue the processflow by navigating to another record to execute a second report on.

The SF offers you several process actions to accomplish this:



Is this the solution you are looking for?

Regards,
Erik
View original

8 replies

Userlevel 3
Badge +3
Hi Dennis,

I think the best way to accomplish this is to navigate to a row using processflows, execute the report and continue the processflow by navigating to another record to execute a second report on.

The SF offers you several process actions to accomplish this:



Is this the solution you are looking for?

Regards,
Erik
Userlevel 1
Badge +2
Hello Erik,

Thanks for your reply. It makes sense to use your approach.
That is why I tried it. Unfortunately something is still not working as expected. Please be so kind to look at my process flow (attached to this post) and tell me what I am doing wrong here (I am on 2017.1).
What I notice is that 'go to next row' isn't returning a row and never continues on the successful path. I tried to activate the grid before the 'next row' step, but that's not working either.
I checked and 'go to first row' returns the first row, so that is working as expected.

Regards,
Dennis.

Userlevel 1
Badge +2
In addition to my post above:
It looks like the report deactivates the collection of record and as a result of that there is no collection of records anymore to get the next row from.
If I am right then I need a way to get the focus back on the original record of the original record set, before selecting the next row. When I place the 'go to next row' action immediately after the 'go to first row' action I get the report of the second row of the collection.
Userlevel 3
Badge +3
That's not what I should expect the GUI to do. There are some reasons to think of why the user can't switch to another row, like being in editmode or in case to other rows are available.

Do you use an up-to-date GUI?
Userlevel 1
Badge +2
We use GUI 2018.2.19.0.
Userlevel 1
Badge +2
Dear Erik,

I just found out that when I use the flow on the original subject (not being a variant) it works like a charm!
Now I have to do some additional research first, since when I use it on a variant, the next row action is not working as expected. I first going to see how this variant is configured and then I get back to this post.

Thanks so far...
Userlevel 1
Badge +2
I found out that my process flow is working as expected. Even on variants.
The problem occurs when the process flow is fired from a nested tab page. Then the records from another tab page are used in the 'go to next row'. I am going to contact your helpdesk for this.

Thanks for your help!
Userlevel 3
Badge +3
Thanks for your illation. Nice to know you are helped by my answers!

Regards,
Erik

Reply