Solved

skip validation in IAM by default

  • 22 February 2019
  • 8 replies
  • 147 views

Userlevel 4
Badge +10
Is it possible to skip validation in IAM by default when synchronizing a model? We still have to solve several validation messages from older development which we simply didn't have the time for yet. Also since we do validation checks in SF of current development we don't really need it in IAM as well.
icon

Best answer by Diederik van Duuren 25 February 2019, 13:57

Roland, I just gave you access within TCP to the hotfix downloads. You can find it within the menu item 'Software' --> Thinkwise Products'.
View original

8 replies

Userlevel 4
Badge +5
Hi Roland,

It isn't possible to disable the validation check before synchronizing your model. However within the menu item Global setting (Within the IAM application) you can set the minimum required validation severity. By altering this setting you can prevent the validation error to popup whilst not all information and warning validation checks have been solved.
Userlevel 4
Badge +10
Hi Arjan. That will work for us in normal circumstances. What triggered my question is that we have a problem on our hands after the suite upgrade to 2018.3. There seems to be an error in the validation code resulting in a very slow validation process in SF and not being able to synchronize a model in IAM.

The problem happens in the step "Columns with undecided sensitivity" and the error message we get after a long time-out is:

code:
val_col_data_sensitivity_undecided: Arithmetic overflow error converting int to data type numeric.


I've looked into the debug info in SF but it doesn't provide more info than that. Do you know if there's an easy fix for this? Perhaps the deployment tool didn't update the data model propery. I have already posted the issue in TCP but so far I didn't get a response. If it's necessary to start a new topic here about this issue then I'll do that.
Userlevel 4
Badge +10
Quite possibly this validation message in SF is a related issue:

Userlevel 4
Badge +5
Hi Roland,

Good to hear you've already posted an issue regarding the error being displayed during the validation procedure. It shouldn't be necessary to create a topic regarding this issue on community. If you'd like an update regarding this issue, you could try to post a feedback message, in which you can ask for an update regarding the status of the issue.

Regarding the validation error 'Manually created validations have to be edited', are those validations created by a colleague or yourself?
Userlevel 4
Badge +10
The deployment tool that upgraded the suite to 2018.3 must have created those. I haven't and I'm the only developer using this SF. :)

I will keep an eye on the tcp ticket.
Userlevel 5
Badge +2
The problem happens in the step "Columns with undecided sensitivity"
Can you download and run the hotfixes for the Thinkwise Platform? This has been resolved quite recently.

We'll have take a look at the other validation messages - they are not supposed to be there. Feel free to delete these 3 validations if they give you any trouble.
Userlevel 4
Badge +10
I'd like to get these hotfixes but my account in TCP still doesn't have access to software downloads even though it is supposed to. Could someone perhaps enable access for me?
Roland, I just gave you access within TCP to the hotfix downloads. You can find it within the menu item 'Software' --> Thinkwise Products'.

Reply