Solved

ZIP process action not working

  • 15 November 2022
  • 3 replies
  • 96 views

Userlevel 3
Badge +7

I’m trying to use the new ZIP connector to zip a folder.

With the following input parameters.

The input parameter ‘Source file or folder (pointer)’ suggests that I can use a folder path. However I can’t seem to get this working.

Indicium log file shows the following error: “The parameter 'Source file or folder (pointer)' was provided with an invalid value.”
I’ve tried different folder paths but keep getting the same error:

Are folders not supported?
Can I choose a source folder outside the file storage location that is linked to the process action?

icon

Best answer by K.Bakkenes 17 November 2022, 14:24

View original

3 replies

Userlevel 5
Badge +10

The file should be an absolute path, see documentation. :

https://docs.thinkwisesoftware.com/docs/sf/process_flows_actions#zip-file

Userlevel 3
Badge +7

Hi @Erwin Ekkel,

this is the complete path: “\\twisodev01.isodev.loc\ThinkWise_Software\Applicaties\EVO\Generated scripts\GEN_AUTOMATIC_SMART_PACKAGE\1.01\Deploy\”.
However I don't think folders can be ‘absolute’ paths.
 

 

Userlevel 3
Badge +7

I've got it working on Indicium 2022.2.16.2. 
The file path is still the same. “\\twisodev01.isodev.loc\ThinkWise_Software\Applicaties\EVO\Generated scripts\GEN_AUTOMATIC_SMART_PACKAGE\1.01\Deploy\”

The storage location for the process action is “\\twisodev01.isodev.loc\ThinkWise_Software\Applicaties\EVO\Generated scripts\”.
 

Zip file input


At first I was confused because I couldn't find the created .zip file. But after reading the documentation more carefully I came to the conclusion no file will be created:
 

Zip file output​​​​


So I added a ‘Write file’ connector to create the .zip file (by using the binary) on a different storage location.

Zip folder to binary and write zip file to a storage location

Write file input

 

Reply