Solved

We stopped hearing from indicium (containerized setup)

  • 20 March 2023
  • 2 replies
  • 54 views

Userlevel 6
Badge +16
  • Thinkwise Local Partner Brasil
  • 421 replies

How does the GUI exactly determines if Indicium is running? 

The fact is that indicium is running, but from the SF it says it's not. 

 

My setup is that SQL server and Indicium are running in a virtualized container on non standard ports. 

If I look at the IAM. the agent check-ins do function.. I see up-to-date log entries. 

 

 

icon

Best answer by Mark Jongeling 20 March 2023, 13:59

View original

This topic has been closed for comments

2 replies

Userlevel 7
Badge +23

Hi Freddy,

The Software Factory has a system flow (system_flow_agent_check_in) running in the background every 30 seconds to determine Indicium is still executing system flows, therefore knowing Indicium is still running. In the situation where this system flow is not executing (properly), the SF can detect that by checking a value stored in the SF database.

So it could be that Indicium is active, but not executing any system flows. Double check if the Indicium has the Agent: true in its appsettings.json, and that all system flows of the SQLSERVER_SF application inside IAM are having an active schedule. 

Hope that clears it up 😄 There are also a number of other topics related to this exact message on the Community, if the above info is not enough, the other topics may provide the answer

Userlevel 6
Badge +16

Hi Freddy,

The Software Factory has a system flow (system_flow_agent_check_in) running in the background every 30 seconds to determine Indicium is still executing system flows, therefore knowing Indicium is still running. In the situation where this system flow is not executing (properly), the SF can detect that by checking a value stored in the SF database.

So it could be that Indicium is active, but not executing any system flows. Double check if the Indicium has the Agent: true in its appsettings.json, and that all system flows of the SQLSERVER_SF application inside IAM are having an active schedule. 

Hope that clears it up 😄 There are also a number of other topics related to this exact message on the Community, if the above info is not enough, the other topics may provide the answer

Duh.. I had 2 indiciums to the same IAM so one appsettings had agent : false..  I copied the wrong one.. That setting is back to true.. works again..