Solved

OAuth connector gives blank screen


Userlevel 1
Badge +1

I am trying to use the OAuth connector to make a synchronization with the tax service platform of the British Government.

I have followed the docs and set everything up accordingly. However when the proces action of the OAuth login connector is reached, a white screen comes up and nothing is happening.

 

I assume thinkwise is adding the client_id, scope and redirect_uri to the Authorization URL? I was hoping to find more information in the debug screen to find out what URL’s etc are being called, but that is not the case.

 

Can someone tell me what I am doing wrong here?

 

I below screenshots you can see my settings.

 

 

 

Settings in OAuth servers

 

 

 

 

 

 

White screen. Nothing happening.

 

 

 

 

My proces flow

 

icon

Best answer by Mark Jongeling 8 November 2021, 10:13

View original

17 replies

Userlevel 2
Badge +2

Hi pvleeuwen  i have the same problem,  trying  connect to  Rabo bank.  Connecting to office365 works fine.

Userlevel 1
Badge +1

@Mark Jongeling Any update on this?

Userlevel 7
Badge +19

Hi,

Sorry, missed this topic :sweat_smile: but got my coffee ready.

What you can try is putting the returned authorization URL into your browser and see if you still get a blank screen. If that is, that would explain the blank screen. If not, then it could be a configuration problem. 

Userlevel 1
Badge +1

Hi,

Where can I get the returned authorization URL? 

FYI: The oAuth connector is not popping up in the processflow monitor.

Peter

Userlevel 7
Badge +19

Hi Peter,

The authorization URL should have been visible in the process flow monitor as far as I know but alternatively you can use Process procedure logic on your process action to write the authorization URL to a Log table (just temporary - can be removed later).

Or maybe you can print it to the Debug using "print @url” or “tsf_send_message @url, null, 0;”

Hope this helps

Userlevel 1
Badge +1

Hi Mark,

I don’t know where to find the authorization URL in the oAuth connector.

 

The only think I have to save is the access_token(right?) and as expected, I can access that when I create a proces on my process action.

 

Or am I looking completely into the wrong direction?

 

Kr,

Peter

Userlevel 7
Badge +19

Hey Peter,

Personally never worked with oauth yet so I thought the URL would be returned in a way. I think you'll need another program to test the connection to the URL.

I do think my colleagues over at the Windows GUI team can help you out with this more than I can here. I suggest creating a support ticket in TCP so that the team can help you out. They'll need more details about the exact way you are connecting to the Gov.uk URL to see what is returned and where the problem lays.

Userlevel 3
Badge +7

Is this solved already? We have the same problem with connecting to Financial Institutions (Rabobank).

Userlevel 5
Badge +2

@Hugo Nienhuis I ran into similar issues when testing for Office 365, I added some comments to the OAuth blog. Potentially the problem is with the fact that based on current logic, Thinkwise will add &prompt=consent to the Authorization URL and Rabobank Oauth API doesn't support that URI parameter.

You can easily test this yourself by trying the Authorization URL in Insomnia or Postman and see if it works as expected there. Vincent gave detailed instructions here on how to test in Insomnia.

We raised a TCP for our scenario, asking for the ability to set the Prompt setting in the SF OAuth server table ourselves (now it is Read Only and Defaulted to Consent). If it proves to be working using Insomnia/Postman, could you raise a TCP as well? Maybe this speeds up the fixing timelines.

Userlevel 3
Badge +7

@Arie V  Thanks for your reply. We already have a TCP for this and are waiting for a solution as well.

Userlevel 5
Badge +2

@pvleeuwen @eurban @Hugo Nienhuis FYI: Thinkwise released a Hotfix for this and in combination with the Windows GUI 2022.1.13 you can set various Prompt options in the OAuth server table.

Unfortunately, for all of you that's not the entire solution you need, since the Prompt option is a mandatory field in the OAuth table and Tax Services & Rabobank do not expect the parameter at all. The OAuth login connector process action does have the Input parameter Use prompt which you can set to No, but after testing I concluded that this doesn't work, this setting is simply ignored.

Thinkwise will have that fixed in Windows GUI 2022.1.14, so by then you should be able to get it working with the Windows GUI.

In the meantime you can test with Insomnia/Postman to see if you are able to authorize against the desired endpoints based on these instructions from Vincent.

@Mark Jongeling @pvleeuwen The Debug window actually provides clear feedback on the URLs being called by the OAuth login connector.

Userlevel 1
Badge +1

Hi @Arie V ,

Thank you for your comment. We are using this hotfix already for quite some time and for us it’s working successfully. We can now integrate with the Tax Services from HMRC.

Those debug lines are indeed helpful!

 

Thanks!

Peter

Userlevel 5
Badge +2

@pvleeuwen For my learning then: are you using the Prompt=none setting and does that work when calling the authorization URL of the Tax Services, even though the parameter is not mentioned in their docs?

Userlevel 3
Badge +7

@Arie V  - Thanks, we will be looking into this again!

Userlevel 1
Badge +1

@Arie V Sorry for the late reply. I just checked it and none of the values of the login connector are filled.

Userlevel 5
Badge +2

@Arie V Sorry for the late reply. I just checked it and none of the values of the login connector are filled.

@pvleeuwen No need to be sorry. Am just curious to understand the behavior on your side with this service. Would you care to check the Authorization URL in the Debug window and let me know if it does have prompt=… somewhere in the URL?

Userlevel 1
Badge +1

Hi @Arie V ,

I see prompt=consent in the URL.

Reply