Question

max_no_of_records not working for indicium_universal?

  • 30 March 2022
  • 4 replies
  • 29 views

Userlevel 2
Badge +10

We have a table with readings per vehicle. This table is reachable via indicium universal for external parties. They can query by vehicle, sort on date etc etc… That's all fine. But if one forgets to use Ttop=10 of $top=100 for example in the URL, a list of thousans of records can and will be returned.

When setting for example max_no_of_records on a table, the (windows) GUI respects such a setting. Indicium universal however ignores this setting completely. 

Will this be introduced in a future release of indicium universal? And will there be a way to query a variant in the future? 

 


4 replies

Userlevel 4
Badge +4

The page size field is respected..  however the count query to define the number of pages to show will be executed over the whole set.  But performance wise it works, because if you put a page size of 25.. only the first 25 records are returned in the Universal GUI> 

Userlevel 2
Badge +10

@Freddy , not sure what you mean by “if you put a page size of 25”. Where? In the URL?

I changed the file (Default, not Variant, because a Variant cannot be selected from the url as far as I know). Still, if I only query one particular vehicle I get a few thousand results… Not 10 (based upon page_size or max_no_of_records settings, each of which I have set to 10…. Just to see what it does.

If I omit vehicle_no completely (and query a few hundred thousand rows) I blow up the complete webserver… So it would be nice to avoid this somehow, preferably by a setting like below, as I cannot predict what external parties use to query the application.via indicium universal…

 

Userlevel 4
Badge +4

I re-read your question and I understand what you want..  guess this doesn't apply automatically as a default (if one forgets) on direct indicium queries..  would be a good idea… It would definitely have my vote. 

Userlevel 7
Badge +19

Hi,

Universal GUI uses the max_no_of_records setting to limit the number of records by adding the "$top={max_no_of_records}” in its request URL. When requesting data from a table using the Indicium API, the setting is not automatically applied and should be added by the user inside the Request URL.

Reply