Solved

Indicium console log - dbug messages


Userlevel 6
Badge +16
  • Thinkwise Local Partner Brasil
  • 411 replies

I have a question on Indicium logging:

I have Indicium running in containers, and would like to know how to supress console logging, the console log is flooded with these dbug messages. 

 

 

 

icon

Best answer by Vincent Doppenberg 23 April 2023, 17:17

View original

This topic has been closed for comments

10 replies

Userlevel 7

Hi Freddy,

See the docs about controlling the logging levels: Indicium setup | Thinkwise Documentation (thinkwisesoftware.com)

Userlevel 6
Badge +16

Thanks.. 

What is generating these messages?  There is no default procedure…  or is this something that happens in Indicium?

 

 

Userlevel 6
Badge +16

@Freddy i see your last question was never answered. Do you still need help on this? If so, I will check who can help you on this. 

Userlevel 6
Badge +16

@Freddy i see your last question was never answered. Do you still need help on this? If so, I will check who can help you on this. 

Well, there is no blocking issue here, but out of curiosity I would like to know what these messages mean because they fill the logs. 

Userlevel 6
Badge +10

@Freddy I believe this message is added since the Breaking change in Indicium 2023.1.13

I haven’t double-checked, but it could be that this message is shown for every primary key for which the default input/output parameters are still enabled on Subject settings.

Most certainly @Vincent Doppenberg can clarify when exactly this message is logged.

Userlevel 6
Badge +4

Hello @Freddy,

This message is only logged if all of the followings conditions are met:

  • The subject has default logic enabled
  • The subject has an identity column
  • The identity column is marked as default output

You said that there is no default procedure, but I can't see a way for this to be true. Note that it doesn't matter if the default procedure is simply an empty procedure. It could also be the case that the Use default logic checkbox is unchecked in the SF, but that this has not been synchronized to IAM. Or perhaps you are looking at the wrong branch or project version.

I hope this helps.

Userlevel 6
Badge +16

Hello @Freddy,

This message is only logged if all of the followings conditions are met:

  • The subject has default logic enabled
  • The subject has an identity column
  • The identity column is marked as default output

You said that there is no default procedure, but I can't see a way for this to be true. Note that it doesn't matter if the default procedure is simply an empty procedure. It could also be the case that the Use default logic checkbox is unchecked in the SF, but that this has not been synchronized to IAM. Or perhaps you are looking at the wrong branch or project version.

I hope this helps.

It's the latter: 

  • The identity column is marked as default output

But this is done by default in the TSF.. better to not do that by default then. 

Userlevel 6
Badge +4

Hello Freddy,

I believe that we will no longer do this by default in future versions and that there is a new validation that checks for this.

Userlevel 6
Badge +10

@Freddy Totally agree that is should be disabled by default! Please make sure to add your vote to below Idea. 

@Vincent Doppenberg Promising! Haven’t seen any traction on below Idea, but is this planned for 2023.2 already? 

 

Userlevel 7
Badge +23

Haven’t seen any traction on below Idea, but is this planned for 2023.2 already? 

@Arie V  The Idea status reflects the correct state of the implementation. It has not been planned nor has it been placed on our backlog.