Solved

How do we start Indicium automatically instead of manually?


Userlevel 3
Badge +5

I have a challenge when it comes to automatically starting the indicium application. 

:wrench: We're working with the Software Factory Version 2021.3 where the Indicium layer is used in the generation process. 

Correct me if I'm wrong but the message We stopped hearing from Indicium is given when Indicium does not pick up new system flows for at least 60 seconds. This usually means that Indicium is not running anymore and should be reactivated.

 

Scheduled every 30 seconds

This is explainable behavior after rebooting the web server, when the IIS manage server is stopped or when the application pool is stopped or recycled. For all these examples IIS is not automatically starting the indicium application. We should always start Indicium manually by accessing the URL. Indicium will always be accessed by https based on a IIS redirect rule. 
 

When Indicium is running the SF will continue his Generate definition job

 

IIS || Application Pool | Advanced Settings | Start Mode "AlwaysRunnings” | Regular Time Interval "0”

So the question is, how can eliminate the step where we start Indicium manually by accessing the URL and let IIS handle it automatically? 

icon

Best answer by Tim Waalewijn 31 January 2022, 21:01

View original

13 replies

Userlevel 5
Badge +10

Is the hosting module installed? And Is preload enabled set to true?

Note that the Preload feature of IIS will not work correctly if the website only accepts traffic via https, as the preload request is fired on http. A resolution for this problem can be found here.

 

 

Userlevel 3
Badge +5

Yes, we have Preload Enabled turned on and already using the "No redirect on warmup request". 

 

To work around this limitation, you may consider enabling HTTP (unchecked the Require SSL setting under IIS Manager > SSL Settings

 

Userlevel 4
Badge +1

Can you validate that in the `web.config` the rewrite rules are the same as in our latest `web.config`?
I know some customers do changes in the configuration and for that reason don't always update the configuration.

 

Userlevel 3
Badge +5

Before posting my blog I downloaded the latest Indicium folder and placed the web.config in the Indicium application root. 
 

Indicium | web.config

 

Userlevel 5
Badge +10

Did you also check the hosting module if this is present? In older Indicium installers you had to deploy this manually. 
 

 

Userlevel 6
Badge +3

Does the office-dev.niverplast.com website have an HTTP binding as well or does it only have an HTTPS binding? HTTP is necessary for automatic starting to work.
 


Also, is the Application Initialization module of IIS installed on the webserver?
 

 

Userlevel 3
Badge +5

Checked all 3 comments
 

 

​​​​​:ballot_box_with_check:  

 

                                                                              :ballot_box_with_check:

Userlevel 5
Badge +10

Not sure if this impacts the auto start, but does the indicium have it’s own dedicated pool? 

 

Userlevel 3
Badge +5
Indicium Application Pools

 

Userlevel 6
Badge +3

Does the Indicium log contain any errors? Is it possible that, for instance, IIS does attempt to start Indicium automatically after a web server restart, but the database server was also restarted and Indicium fails to start due to not being able to access the IAM database.

Does it work if you restart the web server without restarting anything else?

Userlevel 3
Badge +5

 

:negative_squared_cross_mark: This does not seem to work either. We are using IIS version 10.0.

Userlevel 2
Badge

The only thing I can think of right now is that app init requests are always sent using localhost as the host, while your binding is specifically set to your domain.

So maybe that is why it is not going through.

That is merely a guess though and I cannot remember that being a requirement for getting it to work. The servers I tested with last year were fine with not even having a http binding at all.

Looking at your screenshots everything else seems correct as well.

Try logging the request using PerfView and see what response (if any) you are getting back.

Here is a good blog post detailing how to do that if you need help: https://www.stefangeiger.ch/2021/05/05/iis-application-initialization-troubleshooting.html

Userlevel 7
Badge +19

Hi Dennis, is this question solved?

Reply