date column is empty in export

  • 9 August 2023
  • 6 replies


I have a view with different columns, including a date column (date of birth). In the view, this column has a value, but when I do an export, this column is empty.

Domain is date, like in the table. If I do an export of the source table with the date of birth, the data is available in that export.

Why is a date not exported from a view?



Best answer by Edo Spijker 10 October 2023, 17:15

View original

This topic has been closed for comments

6 replies

Userlevel 4
Badge +3


Which GUI and GUI version does this concern?
I have just tried to test this myself in both the latest Windows version as well as the latest Universal version and the export displays the data value just fine.

If you can provide us with a bit more detailed information, we might be able to help you 😄


Windows GUI: 2023.1.10.0

Build: gfbb8cb3


Didn't try the universal GUI. We don't use this at the moment, because it doesn't offer the required functionality

Userlevel 4
Badge +3

I have tried this with three different domains, a domain with the DATE datatype, one with the DATETIME datatype and one with the DATETIME2 datatype. Each one returns the date just fine in the export. 

Might be some stupid questions but just to eliminate them, are you sure that:

  • The date of birth column is actually included in the export? If you export using the Advanced options it might not be mapped correctly, if you export using the Export immediately option, it should be included automatically.
  • The rows returned by the export actually contain data in the date of birth column? Or could it be possible that the rows returned happen to be empty?

Other than that I'm not sure what the cause might be. Maybe someone else has other ideas that I don't 😅

Hi @Renée Evertzen I help @avandervelden with this ticket and I checked all export-options but it didn't work; the column contain data so it cannot be empty. 

When I renamed the column, the export worked perfectly. I got default and layout error but export was OK. I checked it and we hide this date-column in the form for almost every row. 

Solution for now: I took the column name back to the origin and added in the layout statement  @import_mode <> 2 -- export. Now we get the data in the export-file, but..

Is this the correct working of the application? In the grid is this column read-only for the table variant that we’re using.


Tested via SF on Windows GUI 2023.1.10.0

Extended properties:

  • CustomDateMask            - dd-MM-yyyy            
  • CustomDateTimeMask    - dd-MM-yyyy|HH:mm:ss 
  • CustomTimeMask            - HH:mm                
  • DisableZoomIn                - no                    
  • FloatingDocumentSize    - 1350x700            
  • FormAlignmentOfNumbers    - right                
  • HTMLInGrid    - true                      
  • htmlingridoption        - defaultcollapsed     
  • IgnoreDiacritics        - Yes                    
  • MultiselectParameterID    - xml_input_parameters     
  • RibbonDisplay            - opened              
  • ShowButtonbarIndicator    - no     
  • ShowNavigationButtons    - no
Userlevel 2
Badge +1

Hello Gosia,

I would say that yes, this is intended behavior. 
This is based on the assumption that the layout returns that date column as a hidden column.
If the layout procedure returns the date column as a  hidden column, that column will not be shown in the form and will not be added in the export.

It will still be shown in the grid, if the base visibility is more visible than hidden, like ‘read only‘ is.

As you noticed, you can use the importmode to make exceptions for column that you want to have in your export, but not in your form.


Hope this answers your question, if not, feel free to send me a message.

With kind regards,
Edo Spijker

Hi @Gosia and @avandervelden, did the answer of @Edo Spijker help you out? If so could you please select it as best answer?