Column editable on table variant while column in main table is hidden.

  • 2 March 2023
  • 9 replies



I am trying to hide a column on the main table in both the components grid and form while making it editable in the table variant.


For example: 

  • Column: Min_quantity


  • Table: Purchase order
  • Min quantity (hidden)


  • Table variant of Purchase Order
  • Min_quantity (editable)


When I try this, the GUI hides this column min_quantity in both the main table and the variant.


Is this still possible?



Best answer by Vince D 2 March 2023, 16:53

View original

This topic has been closed for comments

9 replies

Userlevel 6
Badge +16

You can, if you hide it in the component tab on the main and set it to visible in the component of the variant. 


@Erwin Ekkel unfortunately this is not true, please see the screenshots below:





screenshot of the grid in the GUI for bunker_purchase_order_line:



Userlevel 6
Badge +16

Are you sure this is the variant? For me it's working perfectly fine. 





@Erwin Ekkel that is very strange, since I am 100% sure this is the variant for the table. 


Has this perhaps been changed in the release of 2023.1? I couldn't find it in the release notes but maybe I missed it.

We are currently running on 2022.2. 



Userlevel 6
Badge +16

Are you testing this using iam or sf? And what version of the gui are you using? 


I am using SF.

The GUI version:



@Erwin Ekkel the problem has been solved, never mind this issue.


You are right that is possible. As I was going through the deployment (creation), I saw my branch was infected with all kinds of look ups and inactive process flows. This problem probably occured when I was copying my project and closed the Software Factory application in the meantime. 

Now that I have set back my project to a previous project version, the above possibility for the subject setting does work.


I hope this makes sense to you. Anyway, thank you Erwin for your quick replies. This is much appreciated.

Userlevel 4
Badge +5

Just checking, mainly because I always tend to forget this, but did you check the rights on the column? 


Yes @Kasper Reijnders, I did but there was nothing wrong with that.