Solved

aunable to login to IAM and SF After migrating our dev/test to another database.

  • 28 October 2022
  • 9 replies
  • 63 views

After migrating our dev/test to another database server and also upgrading IAM and SF. we are unable to login.

the web apps are responding okay, and the database users are there. it’s just that the login is not working. It’s like we’re locked out of the environment. I can’t even login to the Indicium back end to view logs.

Has anyone seen this before and fixed it? I tried some fixes that have to do with orphaned sql users and the like, but nothing has helped so far. i’ve attached screenshots of the errors we receive.

 

icon

Best answer by rustie 28 October 2022, 17:05

View original

This topic has been closed for comments

9 replies

Userlevel 7
Badge +19

Hi,

It looks like your attached images have not uploaded successfully. Could you reupload them? You can paste the images inline with your topic/reply

When restoring a SF/IAM database on another server, most likely some information in the server table is incorrect. In IAM, could you check the server table using this query?:

select * from server

Here you can see all servers configured. The IAM application normally uses "current_server” but this may have changed. Hopefully this query shows the problem.

i only get a message saying : Invalid object name 'server'

 

Userlevel 7
Badge +19

i only get a message saying : Invalid object name 'server'

 

select * from [IAM_DATABASE]..server

Replace the IAM_DATABASE placeholder with your IAM database name. That should do the trick.

isorry, performed the statement wrong. this is hte result:

 

okay so for another IAM database i see the old server name: 

 

 

So as it is all my IAM databases are displaying the old server. all, except the iam for SF. which shows the current server. how do i fix the other ones?

Userlevel 7
Badge +19

Maybe your user is not the Main administrator. You can try adding yourself as Main administrator using this: 

insert into usr_root_admin (tenant_id, usr_id)
values ('1', '[YOUR_USER_NAME]')

This should allow the inserted user to access IAM

running this statement on the IAM of software factory and this is the result:

Msg 2627, Level 14, State 1, Line 1
Violation of PRIMARY KEY constraint 'usr_root_admin_pk'. Cannot insert duplicate key in object 'dbo.usr_root_admin'. The duplicate key value is (1, duane). But my user was a main administrator as i recall

In our case the mixed mode authentication in SQL was turned off. We had to turn it on enable the users for the IAM databases and logins were working again.