443 in file upload link

  • 24 November 2022
  • 10 replies


After I upload a file I am getting “:443” in the upload link. 
Which means I can't access it via external app with the preview link.

Link after file upload:

But if the document is generated it doesn’t get “:443” in the link.

What is causing this? And how to fix it?






Best answer by Vincent Doppenberg 1 December 2022, 17:01

View original

This topic has been closed for comments

10 replies

Userlevel 4
Badge +2

Hi Najambia,

If part of the app is down because of this issue, it should be possible to remove the “:443” with a query on the database. 

update <table>
set my_field = REPLACE(my_field, ':443/', '/')
where my_field like '%:443/%'

Be sure to validate the query if executed on production!

After that, the error should disappear until another file is uploaded from the Windows GUI, but it should at least make it work again temporarily, while we look into this issue.

Userlevel 6
Badge +4

Hello Najambia,

There appears to be an inconsistency between the Windows and Web GUIs on the one hand and Indicium on the other. This causes Indicium to be unable to use the Azure file URLs produced by the Windows and Web GUIs.

We will look into this problem.

Userlevel 6
Badge +4

Hello @najambia and @Edwin van de Peppel ,

We will be releasing a fix for this issue in tomorrow's release, with version number 2022.2.17.0.

Userlevel 6
Badge +4

Hello najambia,

I'm not sure what you mean by “if the document is generated”, but the :443 in the link after uploading is most likely due to how the storage configuration has been configured in the Software Factory. If you look at your storage configuration, you will probably find the :443 in the path there.

I hope this helps.

Hey\y Vincent,

“Generated documents’ are documents that are uploaded to azure via an service. 

We checked the path in File Storage Locations and it is : ff-uploads. And when we still get the :443 in the link when uploading via the upload box in the app.

Also when accessing the document on an external app with the preview link, we get this internal server error: 


Thus it looks like Indicium is giving us this error, whilst it wasn’t the case a few weeks ago.

Userlevel 6
Badge +4

Hello Najambia,

Can you share the stacktrace of the error from Indicium's error log? Feel free to remove any potentially sensitive information.

And is it possible that the files which you have uploaded with the Windows or Web GUI are receiving the :443 port in their URLs in the database and that the files which you have uploaded with the Universal GUI do not receive the :443 port?

Hey Vincent,

The stacktrace is attached. 


After uploading files in Windows or Web GUI the URL receive the :433, but in Universal GUI the link does not receive :443 in the URLs in the database.

Hey Vincent,

I hope it’s resolved asap, because part of our app is down now.

I look forward to hearing from you soon.

Userlevel 2
Badge +3



Is there any indication when and/or if this problem is fixed, as we are experiencing the same error with the combination web UI and universal.




Userlevel 2
Badge +3

Thats great to hear, thanks.