News

End of SQL Server 2012, 2014 support for entire Thinkwise Platform

Related products: Software Factory Web and Windows GUI Intelligent Application Manager Universal GUI Indicium Service Tier
End of SQL Server 2012, 2014 support for entire Thinkwise Platform

The upcoming Thinkwise Platform version 2020.2 will no longer officially support SQL Server 2012 and SQL Server 2014. The official minimum supported version of SQL Server will be 2016.

As of version 2020.1 of the Thinkwise Platform, the minimum version of SQL Server was already 2016 for the Software Factory.

The Intelligent Application Manager, Indicium service tier and the GUI's did not leverage SQL Server 2016 features with the 2020.1 release. With the upcoming release of Thinkwise Platform version 2020.2, this will change, and therefore the entire platform will require SQL Server 2016 or higher.

Impact on development environments

As of version 2020.1 of the Thinkwise Platform, the minimum version of SQL Server was already 2016 for the Software Factory.

Impact on production environments

Version 2020.2 of the Intelligent Application Manager will leverage temporal tables. This immediately brings the minimum required version of SQL Server to 2016 upon release.

The Deployment Center will prevent installation or upgrade of the Intelligent Application Manager to version 2020.2 when the SQL Server version is below 2016 or the database compatibility of the Intelligent Application Manager database is below SQL Server 2016.

Existing products will no longer work on SQL Server 2012 and SQL Server 2014. We advice to upgrade your production environments to SQL Server 2016, before upgrading the Thinkwise Platform to 2020.2.

Timing

Thinkwise Platform version 2020.2 is planned to be released in June 2020.

The changes in SQL Server version support will be reflected in the lifecycle policy.

SQL Server

In our blog language features several new T-SQL features in SQL Server 2016 and 2017 are described.