Solved

Application icon

  • 23 February 2019
  • 1 reply
  • 54 views

Userlevel 4
Badge +10
The extended property ApplicationIcon doesn't seem to work for applications that are run straight from SF database. I set this property in SF under runtime configuration.

I also set Animations (no) there which works.

Is this a known issue?
icon

Best answer by Anne Buit 25 February 2019, 08:43

Hi Roland,

The application icon is one of the global settings that is not specific for an application. It counts for the entire GUI.

Because of that, we can't read it as an extended property at application level. If you'd load multiple applications, which one would win?

These extended properties can be configured in IAM at the global settings, but the SF has no global settings. Instead, you can place them directly in your INI file.

There are only a few of these global extended properties and even fewer which apply to products running against the Software Factory. See the documentation for more information.
View original

1 reply

Userlevel 5
Badge +2
Hi Roland,

The application icon is one of the global settings that is not specific for an application. It counts for the entire GUI.

Because of that, we can't read it as an extended property at application level. If you'd load multiple applications, which one would win?

These extended properties can be configured in IAM at the global settings, but the SF has no global settings. Instead, you can place them directly in your INI file.

There are only a few of these global extended properties and even fewer which apply to products running against the Software Factory. See the documentation for more information.

Reply