Solved

"Field in next column" not working in formlist

  • 8 October 2019
  • 3 replies
  • 41 views

Userlevel 4
Badge +10
For a detail tab with a fixed amount of rows per parent item I opted for a formlist without a grid (to have radio buttons in a pseudo grid to minimize mouse clicks). The tab has 3 displayed columns. To get all fields in a row I selected "field in next column" for the 2nd and 3rd column in "subjects > components > form". That doesn't work however.

To illustrate the problem I made a screen type for this tab with both a formlist and a standard form of the same table, stacked on top of each other. There's only one row in the table. This shows that "field in next column" works in a normal form (bottom) but doesn't work in a formlist (top):



The labels of the first and third column are hidden (0 width).

Is this a known issue?
icon

Best answer by Mark Jongeling 8 October 2019, 12:37

Hey Roland,

I guess it only works for Forms and does not work for Formlists.

If you are looking to put all column values behind each other, you should set 'Field no of positions further to 0' (I believe you want this)
or to put them under each other, set it to 1.

Hope this helps you out!
View original

3 replies

Userlevel 5
Badge +10
Hey Roland,

I guess it only works for Forms and does not work for Formlists.

If you are looking to put all column values behind each other, you should set 'Field no of positions further to 0' (I believe you want this)
or to put them under each other, set it to 1.

Hope this helps you out!
Userlevel 4
Badge +10
Yes this gets me what I want. Thank you!

One more question: is is correct that there are no buttons possible under a formlist? I enabled default editable and auto-save form to get around this issue and probably also is the best option here but thought I would check anyway.
Userlevel 5
Badge +10
As far as I know only editing is possible with the Formlist currently. It's a good idea to post here on Community 😉

Reply